Shotcut crash on startup

As soon as I open the application, the window appears but crash about 5 or 10 seconds later, without me having clicked anything!
Already tried to delete all configuration files and reinstall!

I have attached some logs that may help:

Report.wer.txt (32.0 KB)
shotcut-log.txt (27.3 KB)

SO: WIndows 10 Version 1903 (OS Build 18362.476)
Shotcut: 19.10.20

Thanks.

From the log

[Warning] <> QQuickWidget::resizeEvent() no OpenGL context

The OpenGL to DirectX translation layer we are using called ANGLE from the Chrome project is not working on your system. That is unusual for a GTX1080. Maybe you have installed something that interferes. You can try native OpenGL (not translated to DirectX) by setting the opengl registry key as mentioned here:
https://shotcut.org/notes/configuration/

We default to DirectX on Windows instead of OpenGL because that is more reliable across most systems.

Of course, you can try rebooting before anything.

1 Like

I still don’t know what happened (I don’t change any configuration), but after I restarted my PC, the app went back to working again!

Thanks.

The same problem happened again, and this time I tried to restart my computer several times and the problem continues. The logs look the same as last time!
Tweaking the configuration you suggested (editing the ‘opengl’ key) worked! At least for options ‘0’, ‘15’ and ‘17’. Option ‘16’ causes the program to crash!

shotcut-log.txt (27.2 KB)

Is there anything I can help me figure out what may be happening here on my computer? Everything else seems to work fine…

Thanks.

Use what works. That is why options are offered. Unfortunately, I found the automatic option (not our algorithm) chooses OpenGL native too often or optimistically, and I had to direct many more people how to switch to DirectX.

1 Like