Shotcut 210501 - export video displays INVALID

Been using Shotcut for a while.

Just updated to 210501, everything is fine editing, all images/video/objects display fine in the project window, but I go to export and the video file on playing it just says “INVALID”.

I do not have any proxy on, I have tried to export with/without hardware encoding, export with a different setting, and all my files are valid in the playlist. Still “INVALID”.

The only error in the logs is:
[Error ] [producer_xml] failed to load producer “”

Now I’m stuck because this new version (if I’m not mistaken) cannot be loaded in older versions of Shotcut.

I hope it’s something small I’m missing.


I believe this is a duplicate of the following

Ok, I am not opening MLT as clip, nor am I using a proxy.

While editing, everything is fine. All clips are fine, display properly, add properly, playlist files all load fine. It’s only on export that the whole video is just “INVALID”.

But if I duplicated, I apologize. Maybe they are all caused by the same bug. I searched for my exact issue and didn’t find one.


Yes it can in 21.02 or 21.03. The project will be repaired and you will lose and usage of the new Time Remap. I suggest that you downgrade so you can resume work.

I do not know if your problem is exactly the same. The error suggests the temporary XML file name is empty, but I do not know how that can happen. It does not happen for me and thousands of others who have not reported this. I hope it is related to the same bug. Are you exporting to a special folder such as that synced with cloud?

Thanks for your quick reply.

I will downgrade, and hopefully have no issues. I too hope the issue is related to the same bug, hopefully being fixed in the next release for myself and thousands of others.

Nothing has changed in the creation, files, locations, etc. All the same format as usual.

No, not exporting to a cloud, everything’s local.

Thanks again.

Yea, I am still getting the same error. Still INVALID as I go to Open MLT as clip.

Example -->

Please read the 1st reply in this thread.
It’s a known bug.
Fixed in the next version.

This topic was automatically closed after 90 days. New replies are no longer allowed.