Shorten the tracks


#1

Shotcut 19-04-30 - Mac OSX 10.11

Create or open a project.
Add a clip on the timeline.
Select “Shorten Tracks” in the Timeline menu. The track (s) are shortened.
Apply a filter (with keyframes) to the clip.
In the “Keyframes” view, the track is also shortened.
Save the project and quit Shotcut.
Open this project again.
In the Timeline, tracks are always shortened.
Select the clip with the filter and go to the “Keyframes” view
The track is not shortened.

Before saving the project
26

After re-opening the project
17


#2

Another bug in the management of keyframes.

I have a project with 2 video tracks
On track V1 a clip without filter
On track V2 a color image “Black” on which I apply the filter “Mask: Simple shape”
I click on the “Keyframes” buttons of the “Horizontal” and “vertical” parameters
In the window “Keyframes” I have the 2 tracks “Horizontal” and “vertical” is normal.
I create a new keyframe on the “Horizontal” track. In the “Filters” window, I always have the 2 “Keyframes” buttons selected, it’s normal.
I save the project and I quit Shotcut.
If I open this project again, the “Keyframes” button of the “Vertical” parameter is no longer selected. And yet in the window “Keyframes” I still have the track “Vertical” !!!
See the screencapture below


https://streamable.com/kjn47


#3

Followed your steps could not reproduce with Windows 10 or Linux.
Maybe it’s a MAC issue, or because your locale uses comma for decimal.


#4

Thank you @sauron for this precision.
On your Linux and Windows systems if you leave a project with “Shorten Tracks” disabled, when you open the project again this option is always disabled?

15

with Mac, I have to select it at every opening.

I try your suggestion by replacing comma by point for decimal, but it’s the same.


#5

Yes.


#6

I did the test on my MBP with MacOS 10.10 and an old version of Shotcut (18.12.23) and it’s always the same.
So it’s certainly more related to MacOS than to my particular system.
Other MacOs users may be able to confirm.

Thank you @sauron for your help.