SC 23.05.14 not working on my computer

Ever since the new QT6 version (including the original BETA) I am unable to load SC on my W10 computer.
I have uninstalled all previous SC versions, and selected the option to delete all old files…
I get the SC splash screen, then after a few seconds, it disappears:

My W10 computer specs are:

Device name xxxxxxx
Processor Intel(R) Core™ i5-2310 CPU @ 2.90GHz 2.90 GHz
Installed RAM 8.00 GB (7.88 GB usable)

System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 10 Home
Version 22H2
Installed on ‎10/‎08/‎2021
OS build 19045.2965
Experience Windows Feature Experience Pack 1000.19041.1000.0

Shotcut does work on my newer laptop which is Windows 11:

Device name xxx
Processor 12th Gen Intel(R) Core™ i7-1255U 1.70 GHz
Installed RAM 16.0 GB (15.7 GB usable)

System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 11 Home
Version 22H2
Installed on ‎26/‎01/‎2023
OS build 22621.1778
Experience Windows Feature Experience Pack 1000.22642.1000.0

Any ideas why it’s not working? I can’t believe I can be the only one with this problem. Also any ideas about what I could try to rectify it? I dearly want to be able to run SC on my desktop machine as well as on my laptop… Cheers for any assistance!

I just had a silly idea Jon.
Did you try Run as administrator?

1 Like

It won’t be silly if it works… hang on…

Dammit, no, it doesn’t make a difference. Still no SC. Sob. :unamused: Thanks for the tip though…

See this thread about GPU and a debug build to generate a crash report

1 Like

Ah, great, thanks @shotcut Dan. Here’s the RPT file the debug build generated. Am I guessing right that my computer is just too old to run the latest SC version now? It is an ancient computer…

BTW How can I check the GPU on my computer?

shotcut (jonray).RPT (8.3 KB)

Dan - OK my graphics card is an Intel HD graphics (integrated). Is this now incompatible?

GPU details Intel

Your report shows Qt 6 is crashing while trying to use DirectX. Your GPU and its driver needs to support DirectX 11 or 12. You can run dxdiag.exe to see what you have.

Thanks. This is what came up. I don’t really understand much of it. Is my graphics card basically toast now?

What does the System tab show?

Here it is. Ah, it mentions DirectX 12. Could there be hope?

@shotcut, if this helps, these are screenshots from my laptop (windows 11, bought this year), on which SC works OK:

Your version is compatible in theory, but I do not know why it is failing. Maybe there is something in the driver’s Feature Levels, but I could not find anything in Qt’s documentation. There is a chance it will work in a future version after upgrading Qt.

1 Like

So sorry Dan, I just couldn’t understand your last sentence. Did you miss out a word?

change → chance

Ah, OK. Makes sense now.

Did you mean though that when Qt is upgraded next, SC may then work on my computer? Sorry to be thick …


1 Like

Thank you Dan. Brilliant support. I will run v. 22.12 for now on my desktop for now and see what happens in the future.

1 Like

I have an Intel UHD graphics card and I get a similar problem. If I run Shotcut I get the splash screen displayed and it looks like it is just sat their loading. If I click any other open program (say, Chrome for example) and then minimise Chrome, Shotcut is there maximised.

I have several times now, clicked the shortcut for Shotcut, thinking it’s not loaded so I click it again. That one then loads maximised and I see that I then have two instances of Shotcut loaded.

So just try having a program loaded prior to Shotcut, run Shotcut, wait for a minute and maximise then minise the program that was running prior to Shotcut being run, Shotcut may possibly display with any luck.

1 Like

Thanks for the tip, @PaulusMaximus . I can’t try it out right now because I uninstalled 23.05, but when I get a chance I will re-install and give your method a try. Many thanks!

Even though your driver says DirectX 11, the Features Level is the most important because that is specifically about the Direct3D APIs we are using. And here we can see your one system is incompatible.