Repeatedly shuts down

I am running Shotcut on Linux Mint 18.3, on a 6 core AMD processor with 16GB of DDR3 RAM, and I am running the current version of Shotcut, 19.02.28.

When I attempt to edit a video Shotcut shuts down, just as though I had intentionally closed it. It WAS shutting down if I even tried to play a clip, but I reinstalled it yesterday and now it will play video but not allow me to edit it.

More than likely the OpenGL technologies used for Shotcut’s UI and video display are incompatible with the OpenGL implementation on your system. There is nothing we will do about that; it is not a very high bar, but it is for many Linux systems unfortunately. On the other hand, it could be something completely different, but I do not know based on the very little info you have given. I do not experience many crashes. You need to be much more specific:

  • where did you get Shotcut?
  • What is the output of glxinfo | grep OpenGL? (more than likely I do not have your GPU)
  • What exactly is “attempt to edit a video?” What are the repeatable steps to make it crash?
  • Does it work with a color clip? (Open Other > Color)
  • What is the gdb backtrace? (instructions not provided but in case you know how).

If you are using the nouveau X driver that might be your problem.

I’ve been using Shotcut for a year or so. I originally got the AppImage file from this site, and yesterday got the replacement file for the reinstall here as well. THe last time I used it was a month ago and it worked fine, then yesterday the problems began.

bob-h@bobh-desktop ~ $ glxinfo | grep OpenGL
OpenGL vendor string: nouveau
OpenGL renderer string: NVC1
OpenGL core profile version string: 4.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
bob-h@bobh-desktop ~ $

“Attempt to edit video” meand manipulate the clip(s) in any way, EXCEPT I can apply filters and cut parts of a clip and remove. Everything else shuts down Shotcut.

All clips I have tried are color.

No idea what gdb backtrace is.

Does the previous version 19.01 work better? If so, it might be the Qt upgrade is less compatible with mesa+nouveau.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.