Rendering of rich text filter need antiliasing

The image talks for itself

image

You are showing the preview quality of the rich text editor. That is simply the way preview shows. If you deselect the filter by selecting another filter or clip, it will improve. When you export, it will be better than preview.

Nope it is from the video exported.

Using snap package on Ubuntu 20.04:
shotcut 20.09.13 70 latest/stable meltytech✓ classic

I can confirm that with different fonts!
Resolution 1920x1080.

If the text is on a transparent clip, you need something on the track bellow. If the text is on a black clip, it exports fine, no matter what.

3 screen captures from mp4 export, 1920x1080
(click on the images to see full size)

01 - Text on transparent clip. No track under

02 - Text on transparent clip on track V2. With black clip on V1

03 - Text on black clip. No track under

1 Like

I can’t confirm it on my end.
Resolution 1920x1080 exported frame from exported video via Shotcut.
Times New Roman
V2: Transparent clip


When I saves the HTML via the Rich Text menu option I get the following.

I was using a transparent PNG clip with a gradient on it to make the background black. Without the gradient the issue is there also (in some part of my project I don’t want a background)

When I apply a background on the rich text filter and the text appear correct. This is my workaround for now.

I’ve seen this before in final render too.
my solution was also a background on another lower track. i typically just add a transparent png.
file attached (but you can’t "see it. right click save/view): _SPACER_640x360-transparent-space.png:
_SPACER_640x360-transparent-space
(but as said above, findings maybe different)

This is the same issue as this old bug about Text: Simple

The problem is related to transparent and somewhat out-of-control as far as we could find. This problem could go away if we always make V1 blend with the hidden black background track. Then, we could also change Fade In/Out Video to fade opacity instead of with black. However, these things are they way they are now for performance reasons. (Also, always blending V1 would currently break exporting with alpha.) Maybe this situation will change in the future when everything is rewritten to support 10-bit and GPU.