Rebuild Audio Waveform Not Working

How do you restore the Audio Wafeform?


Rebuild does nothing.

1 Like

You are probably just getting the same result so it appears to not be doing anything.

This happens to me sometimes when I add mpeg files. I get sound but no waveform. And, the rendered output will have no sound. What I do is re-capture the video from the source. If you no longer have the source then SOL.

  1. I have a muted video track.
  2. add an audio track
  3. drag a .wav file into the new audiotrack
  4. select the audio track and cut at cursor position

Result: the audio itself is cut correctly, but the waveform display is not.
It is just copied, from its start, to the new, right-hand side clip, and does not match that clip’s actual audio.
Which makes the whole right-hand side useless for further editing.

  1. “Rebuild Audio Waveform” does nothing.

Only closing ShotCut, and re-Opening the project will rebuild the waveform correctly, but that is just not viable

Incidentally, the thumbnails at the start and end of each clip appear to have a similar problem, in that after a cut the right-hand side clip just receives the same start thumbnail as the start thumbnail of the left-hand side clip.

Edit: Shotcut 18.06.02, Windows 10

Edit #3: the left-hand side waveform is updated correctly, so you can somewhat work around the issue by putting another cut on the right-hand side, e.g. at the very end of the project.

Edit #4: … but then I tried to be really smart and re-join the clips from the “workaround”-cut, which caused the right hand side sound clip to disappear :grimacing:

Shotcut version?

1 Like

Select the clip & refresh via F5

Yes, that’s what I wrote: the audio is fine, but the waveform is not. I do need the waveform for editing audio though; don’t you? It can not be refreshed, either, neither via F5 nor via context menu. I clearly wrote that, too.

From the advice that @Steve_Ledger has gave in other posts, you might wish to try Version 18.03.06.
You can download it here:
Or if you prefer an different version:

Splitting from version 18.03.06 works like it should for waveforms.

I second the above. I need the latest versions of SC because I use key-frames so much but I installed a copy of 18.03.06 to do some audio editing/syncing prior to adding key-frames on a couple of projects as a stopgap and it saved me significant time. Looking forward to 18.07 :smiley:


I’m running the latest 20.04.12 on Ubuntu 16.06 LTS (AppImage as always) and Waveforms still seem not to appear at random, or better said, I have not found the pattern that triggers some waveforms not showing. It happens either in projects with just one video track of a single clip, projects with 1 video (silenced) + 1 audio tracks of a single clip, complex projects with several tracks and clips. The duration of the clip seems not to matter. I have unsuccessfully tried F5 and rebuilding.

The way I get waveforms back is saving the project, closing shotcut and reloading the project in a new session. The main drawback for me is that I lose all the command history.

I am also not seeing the audio waveforms.

It started today, but I don’t know what triggered it.

It is making editing to speech quite laborious.

Rebuilding Audio Waveform doesn’t seem to help.

I have Show Audio Waveforms selected and toggling it doesn’t do the trick.

Unlike Alberto, closing and re-opening Shotcut doesn’t bring it back to life.

I am also running 20.04.12, but on Windows 10.

Are you running more than one instance of Shotcut (also check for hidden, hung/zombie processes)?

1 Like

I fixed the problem by looking through the running programs in task manager after closing Shotcut.

It turned out there was a Shotcut process still running using only a couple MB.

I ended that task, re-opened Shotcut and the problem has not recurred.