Proxy failed 96kHz invalid sample rate

Hi all, when I start the Proxy for a 4k video with 96kHz audio sample rate (.mov file from camera) the Proxy fails with the following report:
[auto_resampler_0 @ 0000017dea4f3940] ch:2 chl:stereo fmt:s32 r:96000Hz → ch:2 chl:stereo fmt:fltp r:96000Hz
[ac3 @ 0000017de5277f00] invalid sample rate
Error initializing output stream 0:1 – Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height

Is it a real bug or it’s my fail using wrong settings?
Thanks and BR
KFL

It is a kind of minor bug. The proxy transcode command line does not specify an audio sample intentionally. So, it passes through from the source. We can specify it to be the Shotcut default 48000. Let me think about if there is a possible drawback to that.

This is a minor comment, but a possible drawback would be that it might mask an artifact that would normally occur. For example, if source material is 44.1kHz, when edited in Shotcut, if you make a split on a clip on the timeline an artifact will occur due to a new audio resampler being created at the split. However, if the proxy has been normalized to 48kHz, then the artifact would not occur in the preview, but it would still occur in the export when not using the proxy.

This problem already kind of exists anyway if you export in 44.1kHz because Shotcut always previews in 48kHz.

In general, I would support normalizing proxy files to 48kHz to avoid sample rate conversion altogether when previewing in Shotcut.

For people who really care about possible artifacts due to sample rate conversion, they should be sophisticated enough to pre-normalize all their source files. We might want to add a sampling frequency option to the “Convert” dialog so advanced users can choose how their audio should be normalized. Might as well add channel layout as well.

1 Like