Problem with stabilization filter on Win7 64 with ShotCut 17.01.02

Hi Everyone,

I recently discovered Shotcut and tried to use the stabilization feature on my shaky camera movies. Unfortunately, I can’t get Shotcut to export a stabilized video.

I’m working on Win 7 64bit with ShotCut 17.01.02 and this is what I tried:

  • Add Movie to Shotcut
  • Add Movie to timeline
  • Add stabilization filter to movie on timeline
  • Analyse movie. Analysis is complete and results are stored.
  • View project in preview. Movie is stabilized. Source shows unstabilized movie.
  • Export project.
  • Exported movie is not stabilized. It seems to be cropped in some way, though.

I tried different zoom levels for the filter but that didn’t help either. GPU support is deactivated and parallel processing as well.

What am I missing to get an stabilized export? I have the same behavior on an Win 10 machine.

Any input is welcome, as the stabilization feature here is much easier to operate for me than e.g. the deshaker filter with virtualdub or the blender tracker.

So in the meantime I’ve tried some more things:

  • running ShotCut (on Win 10 64bit)
    • as administrator or portable: -> no stabilized export
    • v 17.01 32 bit portable -> no stabilized export
    • v 16.11. 64 bit portable -> no stabilized export

When I export a single frame (with the 17.01 64bit installed version on Win10 64bit)

  • with the stabilizing filter on, I get the image shown in the preview (the stabilized image),
  • with the stabilizing filter off, I get the unstabilized image (the one from the source).

For single frame exports the stabilizing filter seems to work.

So after all that tests I’m assuming there is a bug with the stabilizing export.

Should I file a bug report on github?

I have not been able to reproduce it. Try the same steps, but do not add it to the Timeline. You do not need to use Timeline or Playlist for a single clip, optionally trimmed.
What is your Windows region setting and its decimal point setting?

Just tested using comma for decimal point in region settings, and that worked for me as well. Please be aware that you cannot write the .stab with one decimal point setting and then change setting and read it. It must be written and read using the same decimal point setting.

Thanks for the feedback.

I tried it without a timeline and I finally got it to work. When doing that I realized what my error was:

When exporting the video I obviously changed settings like framerate or video size which resulted in an unstabilized video.
When keeping framerate and size exactly to the original numbers, the video will be exported stabilized.

I think I’ll be even more careful in the future when exporting a stabilized video.

PS: I’m working with a German regional setting but I never change that and the regional setting didn’t matter in the end.


I was able to reproduce this as well in Shotcut version 17.09.04 on Windows 7 64 bit by attempting to export 29.97 FPS stabilized source footage at 29.00 FPS. Enabling Parallel processing without changing the export framerate to 29 frames per second does not cause this issue. Modifying the export aspect ratio or resolution also does not seem to cause the issue.

To elaborate on the end result - the exported video that translated around (and/or was cropped) as though it were stabilized, but the video was still visibly shaky, despite the preview of the effect being satisfactory.