Problem exporting if I use size and position and Chroma Key at the same time

Hello, my name is Will I have been trying to make animations for youtube, I have been trying to put my character models in but they have a green background. Transparent backgrounds don’t work, so I use Chroma Key to get rid of the background. The problem then lies in the fact that I have to scale my characters down to put them in the right spots, but when I use the Size and Position filter and the Chroma Key in the same .mp4 file my export fails. I am running on a 64 bit laptop with an AMD A8 processer with 4GB of ram, everything else works fine it’s just this issue, I’ve made many other videos before using shotcut, but this doesn’t seem to be working…it works perfectly fine if I use either filter on it’s own but my exporting always fails if I use them together, I’ve been trying to solve this for two weeks, I searched google for 3 full days. So any help would be very much appreciated, thank you.

Does it work if you disable Parallel Processing in Export?

1 Like

I haven’ tried I will do that and see if it works, I’lll keep you posted. Thank you

okay so I just tried disabling parallel processing and it still failed, is there anything else that might help?

Hi, I can’t help with the bug fix, sadly, as it works OK for me (Linux, Intel, 64 bit 4gig) but just so you can get your work done… if you put your background in place then on separate tracks place your characters then apply chroma to the characters so you can size and position in relation to the background. Then delete the background track and replace it with a single image made up of the green colour that you had on your characters before chroma. Then delete the chroma filter from the characters (actually delete don’t just uncheck) This means in this video you have only used the size and position filter and all your characters are on a solid green ‘screen’ - then export the video.

Now, start a new video, place the background on the timeline, then open the character video on another (higher) timeline and apply chroma to the character video - now you only have the chroma filter in this new video and all should be well - well at least get the job done for the moment. - Best of luck

1 Like

In what order are the filters? Try changing their order. Will try to reproduce it soon.

my filters are Chroma Key above, and size and position below. If need be I could take an OBS screen recording of the process I’m doing if that helps?

I have not reproduced it. I tried with both simple and advanced chroma key. This was on Windows with 64-bit v17.01 of Shotcut. Maybe a screen recording will help.

here is a link to the scree recording

I watched it, and my steps to try to reproduce it were very similar to yours except I did not adjust export settings like you had. I tried that, and again failed to reproduce it. What is your Settings > Video Mode set to? It seems Automatic because the export settings resolution and frame rate were rather odd (and difficult to see in the video). In Automatic mode, it uses the same resolution and frame rate of the first clip you add to your project (Playlist or Timeline). The problem might be affected by the attributes of that first clip (what is its resolution and frame rate?).

Try this:

  1. start Shotcut
  2. in Settings > Video Mode, choose 1080p 30 fps
  3. assemble the project
  4. export should now default to 1080p 30, leave those settings
  5. choose Export File

If the export fails, right-click the job and choose View Log. Then, copy & paste that here, or save it and attach it.

alright I put those settings in and assembled it, and it did fail so here are the details and I’ll go check the details for the background video since that’s normally the first one I put in, but here is the log

[libx264 @ 0000000004f7bbc0] using SAR=1/1
[libx264 @ 0000000004f7bbc0] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX LZCNT BMI1 SlowPshufb
[libx264 @ 0000000004f7bbc0] profile High, level 4.0
[libx264 @ 0000000004f7bbc0] 264 - core 148 r2744 b97ae06 - H.264/MPEG-4 AVC codec - Copyleft 2003-2016 - - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=2 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=15 keyint_min=1 scenecut=40 intra_refresh=0 rc_lookahead=15 rc=crf mbtree=1 crf=21.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
Current Frame: 25, percentage: 38

the background video has a frame rate of exactly 25fps and a resolution of 1920x1080 and an aspect ration of 1929x1080

I think I need some of your files to reproduce the problem. If you can/want you can upload them to here:
Specifically, you should provide 2 files: a background and green screen clips that you know together gives you the problem.

alright I’ve uploaded 3 files I had to upload them one at a time because they wouldn’t upload together, but I sent all 3 through

I got the files, reproduced the problem, and fixed it for the next release. In the meantime, to work around it, in the Export panel set Interpolation to Bicubic.


Thank you SO much for your help, this has been a difficult process so I’m really grateful for the help.

1 Like

Just to make sure you know, the OP’s problem I reproduce as well, even with the newest release. I did copy out the log for you in case you want it. Amazing we can even see the log, you guys thought of everything! The log correctly shows that the initial resolutions of clips were different (basically some are youtube sharex screen recordings :slight_smile:

So my export attempts too always failed at the same spot: 21% (the clip there is the Queen, but this can’t be the problem lol)

So then I searched for a solution here, thankfully found yours, and set Interpolation to Bicubic like you advised. And indeed that trick still solves it. But it’s needed, for me. Okay?

Bicubic is surprisingly slow, but I don’t mind, I got it exported!