Poor playback on YouTube

Please please, anyone
I have put some videos on YouTube and the quality of the video is poor. I’m using a Gopro 7, shooting on 2.7k, 60 frames per second and then editing on Shotcut. On my computer it plays back fine, but when uploaded and played on YouTube, the film in places is very jerky and not quite in focus, especially when I’m filming from a moving motorcycle. Any help would be much appreciated
yours - Rob Davies

Hi Rob,

what are your export settings? Pls provide a screenshot with the details.
And what is the video mode you are working in Shotcut?
A link to the YT video might be helpful too.

Dear Rilos
Many thanks for your help. You may think me a bit hopeless but I’m a newbie to filming and YouTube, Plus I am dealing with a pretty painful cancer at present so my mind is not always bright.
Anyway -How do I find what my export settings are? also I don’t know what video mode I’m working unless that’s the MP4 output.
I am doing Classic Motorcycle vids and its the moving parts that are the worst. I’m guessing that I should go from 60 to 30 Frames per second.
Here’s a link to one of the vids https://www.youtube.com/watch?v=lAIa_UOm1u8

My channel is The Classic Motorcycles Channel Robert Davies

Also - sorry, how do I provide a screenshot and put it in the reply? I told you I was a novice

I appreciate your assistance
Rob Davies

Hi Rob,

no problem, i am quite new to Shotcut myself, but did some video for the last 10 years.
I watched your video (partly) and i am not sure to what quality flaws you are referring to? Of course, at high movement you cannot expect sharpness and top quality and i have no comparison to the original clip.
For the export setting: you have an export tab (from where you export your video from Shotcut) and you can select the settings (codec, quality, etc.). For YT you should select the “Youtube”-settings and go to “Advanced - Codec” and there you can set the default quality of 55% up to 60 or 65%. This leads to larger video files and a better overall quality (due to lossy compression). You can go up to 100% quality which leads to very large files without much optical increase in quality (to my eyes and screen) but you come to nearly lossless compression.

60 fps is a very high value - good for fast movement - so this is superior to 30 fps - i wouldn’t change that unless you have too big file sizes. Apart from that YT is re-encoding every video to its own format, so there will always be a small factor of degradation. The Youtube-export settings in Shotcut pay attention to the restrictions of YT, so this is the best export choice (with upgraded quality settings to your liking).

The video mode is here: Settings - Video mode. You will find a dot next to your settings. Per default these are automatically derived from the first video clip you draw into the timeline. They should match with all clips you draw into your project. But you can also set the video mode manually.

I hope, that helps :slight_smile:

Cheers, Rilo

Many thanks Rilo I will have a go. Sorry to be slow in reply, but I have so many hospital appointment’s at the moment and am trying to do as much filming as poss before they get me doing Chemo

Best regards Robert Davies

HI Rilo

just had a look at settings and I can’t see any 'codec, quality or settings for YouTube. Maybe they are on a later edition of Shotcut. I am using 19-06-15


Under Presets, there is Lossless with Ut video?


Hi Rob,

for the quality settings you have to be in the export-screen (you have chosen a video format from the list i suppose) than go to “advanced tab” -> “codec tab” - there you have the quality settings.
I dont know how things work in older version, but i guess that this hasn’t changed much. I would suggest to update to the latest versions - there should be no problem.

My best wishes for your health!

Cheers, Rilo

This topic was automatically closed after 90 days. New replies are no longer allowed.