Playing video in shotcut 23.07.29 is worse than 23.06.14

OS: Windows 10 Home
System type: 64-bit operating system, x64-based processor
Shotcut version for reproducing bug: 23.07.29
Shotcut version where bug is not reproduced: 23.06.14
Processor: i7-6700K, 4.00GHz
RAM: 48.0 GB

I had a version of Shotcut 23.05.xx (I don’t exactly remember which). Since it could crash due to memory issues, I decided to update to the latest version. However, in this version, video preview in the timeline started to work with constant delays. I was absolutely sure that everything worked fine before the update.

I checked CPU and memory usage and didn’t see anything that could overload the computer. So, I updated Nvidia drivers and rebooted. Video lagging remained. Then I downloaded the previous version of Shotcut and reinstalled it. I didn’t do any restarts during this process. The video started to play smoothly again, just as it was.

Apparently, the new version of Shotcut has some unnoticed flaw that affects the video playback speed. Hopefully, it will be fixed soon, and for now, I’ll continue to work with the previous version of Shotcut.

I also note another new change in the preview operating mode in version 23.06.14: each piece of the audio track in the timeline, when played for the first time, experiences a long pause, as if it were loading. Then everything is played again without pause. It is especially unpleasant when the audio track is cut into small pieces - at each of them there is a pause and a “click” in the headphones.

This was definitely not in version 23.05.xx

Possibly a duplicate of Every Shotcut version after 22.12.21 skipping around 0,3 seconds audio when pausing and resuming video

I have not really noticed it. I encourage you to test the beta for the next version due by the end of the month.

I added a video to a muted video track.
I added a piece of music (44.1KHz) that has continuous tones like held chords and not just beats on an audio track. I split that music at every second. I play it back, and the music is seamless. I save the project, restart Shotcut, open the project, play it back, and it is still seamless.

1 Like

I think it’s something different. I tried to create a short video from my ongoing work.

That’s original:

And that’s the audio waves of the resulting video I recorded to show you this (possible) two bugs.

Pauses before playing each audio cut (v23.05.07):

Sound shakes (v23.07.29):

I got a third bug - all my animation saved in *.mlt files using “Size, Position & Rotate” filter was totally ruined during switching between Shotcut versions.

Maybe it’s because all new Shotcut instances always set video mode to 1080p although all video sources was 2160p. I hope I will catch this bug and document it in future in different bug report.

The screenshots are helpful. But I am having trouble reproducing the problem you describe. Would it be possible to provide a bare-minimum example project and media that demonstrate the problem?

I also agree with shotcut that it might be good to test the beta.

I will test beta and will try to create example project.

Also I provided a demonstration of the problem, but link was hided in href. Just to be sure you don’t skip it, I provide full link:

I watched the video, and I have not yet experienced that. Does it export like that too?
If it is only playback, I wonder if you are affected by this change in the release notes:

  • Fixed another very old bug on Windows where sound does not follow the default output device, for example plugging headphones, until you restart the app. Please note that if you are using Settings > Audio Channels > 6 (5.1) after the default sound output changes, you will likely experience distortion in the audio playback until you restart the app.

But also see the next note:

  • Added the --SDL_AUDIODRIVER command line option for Windows and Linux.

To fix the problem, Shotcut changed the default Windows audio driver for stereo (Settings > Audio Channels) from directsound to winmm. It is possible that you have a system-wide environment variable SDL_AUDIODRIVER set that changes this, or it behaves different on your system. But the second note lets you change it on the command line, for example:


To do that in Windows, you can either run shotcut.exe from cmd, or change the app icon properties: right-click the app icon, choose Properties, and add the above text after shotcut.exe in the Target field. Values to try are:

  • wasapi
  • directsound
  • winmm

For example
C:\Program Files\Shotcut\shotcut.exe --SDL_AUDIODRIVER wasapi

It’s only playback. Video is always rendered correctly.

I tested --SDL_AUDIODRIVER parameter. Two of three parameters completely eliminate sound reverberation during preview playback (tested on 23.07.29 version of shotcut).

  • wasapi - good
  • directsound - good
  • winmm - sound still reverberates

Without setting SDL_AUDIODRIVER it working badly as described before.

Only one thing left: sound still delays before first time playing any video or audio cut. Looks like all cuts are not loaded yet and only playback is initialize it. If timeline played again it cached and everything played smoothly. And the result video is rendered without that delays.

Then I downloaded 23.07.29 (BETA 2) version of shotcut.

Run without parameter: the sound is reverberating in video layer and additional audio track is not played despite audio cuts in it (I checked Mute icon, it’s not active). Sometimes that was in old versions of Shotcut but it was rarely and after replaying the audio track it working well.

Run with parameter --SDL_AUDIODRIVER wasapi or directsound: sound stopped to reverberate but audio track still not working yet. Also I heard crackling from time to time. Looks like crackling sounds relates to not-working audio track.

That is normal behavior for Shotcut. It must close some clips internally to control memory usage and file handles and then reopen them as-needed. I am not doing anything to improve this for you.

I will not be changing the default audio driver based on your problem and results. There is a very good reason for the current default based on my testing (and the mentioned bug fix). If you need something different, you need to use this command line option. Here is a link to comments about various issues with the different options here based on my testing:

Thanks guys for the very quick replies! I appreciate it.