Pasted audio clip track silent after export


#1

My .mp4 audio track plays under .png frames. I extend the .mp4 audio by clipping a section copying and pasting it in the middle of the audio track. The timeline plays as expected in Shotcut (v. 18.10.08) I export the timeline as .mp4. I replay it on either VLC or MPC. The audio is silent at about 90% of the play. There’s no relation to the audio cut and where the audio is silent. I’ve copied and pasted different sections and I’ve done the same but on a second audio track. The results are the same. What might be the problem?


#2

Solution … add the .mp4 as a video track and turn off its display.


#3

I can’t duplicate the issue.

What does the properties window (in Shotcut) display about your MP4? How many audio tracks are on the MP4? (Audio tab, click on track). Did you use an Export Preset?

This is what I tried to duplicate with. My MP4 is a video file. But in theory I could use them as audio, just by hiding the video. I don’t have any MP4 audio files to test with. Most common audio files are MP3 or WAV.
1 Video Track
shotcut_2018-11-09_05-09-43
1 Audio Track
shotcut_2018-11-09_05-09-57


#4

Thanks for looking into it. Here’s a the video and audio properties. MP4 has 1 audio track. My custom Export Presets presets attached. I did solve it, as I mentioned, by adding the mp4 as a video track and turning off its display.

image
image
image
image
image