Overlay video + Chroma-key | Can't view the main video correctly

Hi everyone,

I am using a first Video (let’s call it A) with a regular size (such as 1920x1080) that I add in the main track of the timeline.
I put a second one in second track as an Overlay video…
That second video (let’s call it B) doesn’t have a regular size ratio (let’s say 1200x300 for instance). This video does have a definite background (green one) in order to be removed by using chroma-key.

When I add it without using chroma key, B is indeed over A green background INCLUDED in the 1200x300 area. I can see A perfectly well in the rest of the main area.

So that’s when I want to use the chroma-key, to remove the B background so that I just get the action from B without its background blocking the view on A.
When I use chroma-key (on green color) on B, it does remove the green background, allowing me to see A where the B section is located… But it fills the rest of the main area of A all black.

To sum up, when I activated the chroma key, I see a 1200x300 area correctly (B+A altogether) whereas the rest of A (which is 1920x1080) is entirely black.

Can someone tell me what I probably do wrong ?

Thank you in advance !

1 Like

Hi Gatsu,

The overlay (image or video) should match the size of the base video.

Thank you for your answer.

The problem is that I don’t want the B video to match the size of the other one, it’s the opposite… I want it reduced to put it in a corner…
Even using the filter “size and position”, resizing it to the original video doesn’t stretch the green background to the original size of the video. And the result remains the same.

I don’t understand because when I use the same method on VSDC Free Editor or Movavi editor, I don’t have that issue and it works fine.
The chroma-key only applies to the B video, without interfering with the A one.
But on Shotcut, it doesn’t work… I don’t even understand why it becomes a black background in the rest of the video…
Why isn’t the filter only applied to the 1200x300 area ?
If I use any other filters, it doesn’t mess around with the A video… So why does this one do ?

Thank you again for your help

1 Like

I have the same problem and could not find a solution to this problem. It seems like chroma-key removes your background of the small video and at the same time makes the outside of your video intransparent (don’t ask me why).

I am still looking for a solution to this problem. I would be glad if someone could describe a solution to this problem.

Can you add a screenshot or even export the video and upload it?
I tried to use a green screen effect with 720p over a 1080p video and it did work as expected.



720p over 1080p should work because it’s scaled to the project size by default, and both are the same aspect ratio (DAR of 16:9) . Something like 1200x300 has a different AR

It’s not ideal, buta crappy workaround within shotcut would be to :

  1. apply “size and position” filter to the video,set to “fit” . This makes it 1:1 (e.g. if you have a 1280x300 asset it will remain 1280x300, not scaled to the project size)

  2. apply “chroma key” filter to the video

3a) apply, as a track filter, “crop:rectangle” to the area of interest (e.g if it was 1280x300, just drag the crop box to include that area)
3b) in the filter, click on the padding color swatch, set the padding color alpha to “0”

If you need to position the overlay, apply “size and position” effect as a track filter , this time set to “fill”, and enter the position settings. You have to click away (e.g. click on track 1, or a blank area) to see the changes

1 Like

I did not think about the aspect ratio. How bizarre that the space will automatically be filled with black.
Hopefully your workaround helps.

If you use the size and position filter, RS filter, or crop rectangle to scale the overlaid green screen video the size and position, RS, or crop rectangle filter needs to be below the chroma key filter. Otherwise there will be black screen.


It worked out. Thank you for your help! The order of effects was important.