No audio wave in timeline (2)

I’m sorry to open a new topic, but the previous one was closed while the problem is not resolved for me.
I am under OSX El Capitan and I used SC 18.01.02
I upgraded to SC 18.11.02
All projects made with SC 18.01 and opened with SC 18.11 do not have the waveform in the timeline.
If I create a new project with SC 18.11 I still do not have the waveform in the timeline.
I have of course tested everything that was said in the previous topic, without success.

So I tried to replace the SC 18.11 “timeline.qml” file with that of SC 18.01, but of course it did not work. So I handed over the original SC 18.11 file and started SC for a new project.
The first video file opened and filed on the timeline has the waveform, but unfortunately not the following ones.
I save the project and if I open it again, it’s the same I only have the first clip that has the waveform.
If I run SC for a new project, none of the clips have the waveform.
Hopefully this will help you fix this bug.

Shotcut version 18.11.18 is the latest (at the time of this post).

Make sure you are aware of the following settings.
Waveforms On
Waveforms Off

While you may or may not be aware of this, others reading may not be.

Using Windows 10 64-bit, Shotcut Version 18.11.18, I was not able to reproduce this issue. There was some issue with the audio waveforms a while back, but those have been fixed.


Thank you for your reply.
I made a mistake in my first post, I installed SC 18.11.18
The box “Show Audio Waveforms” is ticked

So maybe this is a problem related to OSX El Capitan

Maybe you have tried various files, maybe not.

Click on the 2nd file in your timeline, and go to Properties.
Shotcut only recognizes 1 audio track (2 channels) per video file. If you have 2 audio tracks, track 1 perhaps muted, while track 2 contains all of your audio, try switching to track 2 in this selection. By default on a Video file, track 1 audio is always selected.

I have the audio set to none, and the waveform goes away.

And if there is no audio at all, this is what will display

I did not apply any filters on these videos
In this picture, they are the same clips but reversed.
Clip # 2 that did not have the waveform now has it since it is first.
Conversely, the # 1 clip that had the waveform no longer has it since it is second16
I only have one audio track on the clips

But I just discovered something that could help you
I run SC and select “open a file”
My first file is loading.
If I click on + (timeline) to put it on the timeline, it owns the waveform.
If I first click on + (playlist) and then on + (timeline) it does not have the waveform
But for the second file, whatever the order, the file never has the waveform

I only have one audio track on the clips

I tried to reproduce it following these steps, but it worked for me. If I cannot reproduce, I cannot fix it:

Thank you Dan,
I understand that it is difficult for you to fix this issue.
I just downloaded SC 18.11.18 on my Macbook with OSX Yosemite, and it works.
So the problem is either OSX El Capitan or a file that SC needs and I do not have or that is corrupted. But I have to find which one. Maybe someone on this forum has an idea ?

Maybe it is somehow related to the number of CPU threads (cores * hyperthreads) you have since background threads are responsible for waveforms and other things. But the number of background threads is intentionally limited by the number of CPU threads to prevent over-utilization. Yes, it could also be an OS version related issue. What are the CPU thread counts on your two machines. Meanwhile, I can try to reproduce it with this new information.

Here is the information of my 2 computers

Informations matériel :

Nom du modèle : iMac
Identifiant du modèle : iMac7,1
Nom du processeur : Intel Core 2 Duo
Vitesse du processeur : 2,4 GHz
Nombre de processeurs : 1
Nombre total de cœurs : 2
Cache de niveau 2 : 4 Mo
Mémoire : 4 Go
Vitesse du bus : 800 MHz
Version de la ROM de démarrage : IM71.007A.B03
Version SMC (système) : 1.20f4
Numéro de série (système) : W880140EX86
UUID du matériel : 00000000-0000-1000-8000-001EC2077974

Vue d’ensemble du logiciel système :

Version du système : OS X 10.11.6 (15G22010)
Version du noyau : Darwin 15.6.0
Volume de démarrage : iMac SSD El Capitan
Mode de démarrage : Normal
Nom de l’ordinateur : iMac XXXXXXX
Nom de l’utilisateur : XXXXXXXXXXXXXX
Mémoire virtuelle sécurisée : activée
Protection de l’intégrité du système : activée
Temps depuis le démarrage : 2 minutes

Informations matériel :
Nom du modèle : MacBook Pro
Identifiant du modèle : MacBookPro7,1
Nom du processeur : Intel Core 2 Duo
Vitesse du processeur : 2,4 GHz
Nombre de processeurs : 1
Nombre total de cœurs : 2
Cache de niveau 2 : 3 Mo
Mémoire : 4 Go
Vitesse du bus : 1,07 GHz
Version de la ROM de démarrage : MBP71.0039.B0B
Version SMC (système) : 1.62f7
Numéro de série (système) : W80445KBATP
UUID du matériel : F886A803-4A1F-5B01-9235-C640A7500E11
Capteur de mouvement brusque :
État :Activé

Vue d’ensemble du logiciel système :
Version du système : OS X 10.10.5 (14F27)
Version du noyau : Darwin 14.5.0
Volume de démarrage : Yosemite sur HD
Mode de démarrage : Normal
Nom de l’ordinateur : MacBook XXXXXXXX
Nom de l’utilisateur : XXXXXXXXXXXXXXX
Mémoire virtuelle sécurisée : activée
Temps depuis le démarrage : 18 minutes

I just created a new user account on my El Capitan iMac, and the waveform appears well.
The problem comes from my computer.
Do you have an idea of the OSX files that Shotcut uses to draw the waveform so that I can try to replace it ?

No, and you should not be tinkering with OS system files. More than likely, something in your Shotcut configuration is affecting it. You can try to move your existing settings plist file out of the way (e.g. to Desktop temporarily) and restart Shotcut. The location of the settings on macOS is ~/Library/Preferences/com.meltytech.Shotcut.plist
If that worked then you can delete the plist file. If it did not work, you can put the plist file back to that location to restore your settings.

Thank you Dan, my problem is solved!
Moving the existing plist file has not changed anything.
However, I moved the “Meltytech Folder” ~ / Library / Application Support / Meltytech to the desktop and it works.
I lost all my presets, but I have to be able to retrieve them one by one.
This folder created by version 18.01 must have a file that is not compatible with 18.11 ?

There is a db file in there that is a cache of thumbnails and audio waveforms. So, the problem is your faulty waveform is cached. If you restore this db file, and then open the problematic file in the Timeline, right-click and choose Rebuild Audio Waveform that should fix it.

What is the name of this file?

Move both of those files together.

OK, I put the Meltytech folder in its place and deleted the two db files and it seems to work.
I found again my presets, I test a little more and I come back to confirm.
thanks again

Since my last post, I worked with Shotcut for several hours and I confirm that the deletion of the db.sqlite3 and db.sqlite3-journal files solved the problem.
Maybe it will be useful to other users …