New version of Shotcut won't start

My OS is Windows 10

I have the latest version, 64 bit

Since i download the latest version, I tried mulitple times to start Shotcut (tried from the taskbar, and other ways), but it doesn’t open at all, i don’t even see the logo before it opens. The latest version I had (before I did the update) worked perfectly. How can I go back to the other version without losing my saving files ? Maybe it doesn’t work because I don’t have enough space… I don’t know, please Help !

Make sure you are downloading from the official website: https://shotcut.org/download/

For older versions, on this page look for:
2020-11-17_15-54-22

Looking at the log file may help determine issues, and you can upload that file directly here.
C:\Users\user\AppData\Local\Meltytech\Shotcut\shotcut-log.txt
2020-11-17_15-58-13

1 Like

You might have a bad install. Sometimes its files are locked. This definitely happens if Shotcut is running but also when there is a hidden hung shotcut.exe (can be found in Windows Task Manager Details view). You should either:

a) extract the portable version into its own folder and try to run it or

b)

  1. reboot
  2. uninstall shotcut
  3. reinstall shotcut
1 Like

shotcut-log.txt (840 Bytes)

there’s my files, thanks for the help

Follow @shotcut’s instructions, and when reinstalling, check the box to Remove Shotcut Settings From Registry.
shotcut-win64-201031_2020-11-18_17-07-56

2 Likes

I did everything you said, but it’s still doesn’t work. What can I do ?

Ensure your computer meets the minimum specifications.
Shut down all anti-virus applications.

1 Like

I do not know how to fix it for you. You can instead use a previous version that worked. Below is 20.09.27, for example. You can find more in this project area of GitHub:

1 Like

I had the same problem here (portable version). What helped me to solve it sounds a bit stupid: Wait a long time. I left the computer running and only looked at it again after hours and then it was open…
Since then it starts normally again. It just feels very sluggish, but that could be because I’ve only worked with 4k projects since then and/or the hardware support doesn’t want to work anymore - but that’s another issue.
If this will not work for you - and sorry again for the low level trouble shooting ideas - try to open shotcut by double clicking the project file. Dont ask my why, but sometimes there seem to exist differences in how to open Windows Programms.
If this will fail, too: Try using an older portable version. For this try you dont have to install or uninstall anything. Create a shortcut on the startmenu and it feels a bit more “installed”.

Maybe you have done this all before - in this case please be so kind an ignore this post :wink:

Good luck
GOP