Network Located MLT files can only be repaired if copied to local computer

What is your operating system?
Windows 10
I store all files (native and MLT) on another Windows 10 computer that is on a shared network

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.02.27, 64 bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
I have several old .MLT files that reference Native files that I have to manually find with the Shotcut repair function (I think maybe I changed directory names at some point). For some reason when I try to repair a .MLT file from my local computer (opening from the shared location) I get an error, the log shows a bunch of low RAM messages.

“[Info ] Util::isMemoryLow available RAM = 12889700 KB
[Info ] Util::isMemoryLow available RAM = 12890756 KB
[Info ] Util::isMemoryLow available RAM = 12878136 KB
[Info ] Util::isMemoryLow available RAM = 12893164 KB
[Info ] Util::isMemoryLow available RAM = 12825716 KB
[Info ] Util::isMemoryLow available RAM = 12833724 KB
[Info ] Util::isMemoryLow available RAM = 12843540 KB”

However, if I save a copy of the .MLT to my local computer, then manually find the native files this works and I can drag the repaired .MLT file to my network computer.

Not sure if this is a bug, but I wanted to share in case someone else has the same issue.

*Possibly unrelated but I also sometimes have get a save error where I cannot save my MLT file. Log shows “failed to open MLT XML file for writing”, this is in the network location as well. The work around for this is to do a save as and that seems to work fine.

This is simply reporting the current memory available and not errors or actually saying it is low; it is simply reporting the name of a function with “Low” in its name. Many log messages report the function name.

Is it correct assume you are using UNC paths that begin with \\ when you say “network location?”

Good to know.

Yes that is correct.
\computer\disc\folder\folder\file

A workaround for this in the meantime is to map a network drive letter to the share.

What do you mean to the share? The network drive I am using as a stored location is mapped to my local computer.

I mean this
image

This is fixed for the next version.

Ok, so just to clarify, do you mean mapping a network drive letter at the project file level rather than just the disc level that I currently have mapped?

Thank you for updating the next version!

I did not reproduce the problem when I opened the project with missing files using drive letter X: mapped to the network location. I only reproduced a problem when I open the project using a network path that begins with \\. You are being unclear. First, you say that yes you are using a UNC path that begins with \\. Then, you say later “mapped” but not necessarily to a drive letter, whatever that means. Next, you seem to say the network location is mapped to a drive letter. Simply having a network location mapped to a drive letter alone does not make a difference. The difference comes from the path name give to Shotcut.

Sorry you are right I was confusing UNC and Mapped letters. I was initially using what I think are UNC paths (I would call them shared network folders).

Anyway I tried to map the same paths to drive letters in addition to shared network folders (see below). I then tried to repair an MLT file by pointing the MLT to the newly mapped letter path. I got the same error as before.

UPDATE: with version 21.03.21 the mapped drive letter works to open an .MLT file. Alternatively I cannot open a .MLT file from a shared network path.