Missing Files for Blank

You can upload your project file in a reply here, and someone can take a look at it.

1 Like

Shotcut.mlt (43.0 KB)

Your first transition on track V1 is bad (has blank) and 1 frame long making it hard to see. I do not know how it became this way but I can guess through some combination of edit operations, undo, and possibly redo. I removed it for you.
Shotcut - fix1.mlt (39.2 KB)

Thank you so much! that fixed it

[EDIT - SEE POST BELOW - SOLVED!!! :smiley: :grin:]

Hi - I’m getting the same thing now. It worked fine yesterday, I exported and realised there was a slight time-difference between tracks toward the end (a join). So, just loaded it up, and it tells me that “BLANK” is missing. I pressed OK - and it seemed to be working OK - but …

It gives me the same error message as above - “Your project is missing some files” etc. And won’t go any further.

(I’ve done another unrelated video in the meantime - and it worked fine - and still loads fine.)

Any idea? thanks, Alan

[edit - I had a look at the .mlt file - and all the files listed in there are available where they were 2 days ago.]


Once is happenstance.
Twice is coincidence.
Three times is…

I have searched the forum.
No one has been asking for help with a missing file named “blank” until about two weeks ago.

Now there are at least three such cases.

(There was a fourth that I suspect is the same, four days ago, but the question “was it named blank” was never answered.
A fifth suspected case was eliminated; the file had a different name.)

SOLVED!!! I woke up (it’s 1:30am in Australia) with an idea.

In my message above I mentioned there was a slight time-difference which I’d adjusted.

I had 2 cameras running, and they both made multiple files - and with one of them, when I placed file “00042.MTS” immediately after file “00041.MTS”, the camera had left a slight lag, and the sounds didn’t coincide quite. And then when aligning them, it made a tiny segment, which I’d moved to my “invisible” track. I’m not sure how it actually came about - maybe I’d overlapped the 2 files slightly when trying to align??

I tried moving that miniscule piece (between 00:38:16:15 and 00:38:17:03) back to the visible track, and it showed “INVALID”

OK - I backed up - and DELETED that tiny segment:

AND - it all works properly again.

I’m not sure why it happened.


There has been a mysterious “…some sequence of user actions…” that has been causing these tiny artifacts.

But it seems implausible that suddenly this month many Shotcut users all simultaneously began micro-adjusting tracks, which no one had ever done before.

It looks more and more like something changed several weeks ago, perhaps on or about the 29th of January, that is causing Shotcut to handle these micro-adjustments differently.

And now, thanks to the careful observation and reporting by @alanclarkeau, we may have a way to reproduce it.

1 Like

Hello and thank you very much for the support.

For not english speakers, could you elaborate on what exactly is meant by “blank” I preaviously had several “empty” spaces between clips where the window would go full black and that was both wanted and ok.

I now get the “Blank” issue preventing me from exporting the projekt… I don´t know what to look for and how it looks like in order to fix the issue (the way others in this thread have done it)

I started having problems when I added an aditional audio track so I now have to audios playing at the same time (music in loop in the background)

I would be very helpful if enyone could help me, I cannot continue with my work.

Thank you guys!

It looks like a very short clip on the timeline that you do not recognize as something you actually want in that place.

Ok, thank you!

I found it. A gap just after a clip and before a transition (where it shoulnd´t be)

Thank you guys!

1 Like

Great to hear you found it. For the next version, these “blank” will no longer be considered a missing file and block export or appear in a Missing Files dialog upon project load. They will still be in the project, but usually that does not appear as something ugly in the export.

1 Like

Hello everybody
Can anyone help me, I have deleted any empty space!

yea so i have found the exact problem, its due to when you have any form of gap between a transition of some sort and the footage. I had to look through my entire video to find it.

i have tried looking at every microscoping thing and I cant find the problem @shotcut please help me

Good morning. Since the last update, I have had the same problem three times. When exporting the file, I was told “file blank missing”. I have read the discussion carefully, but despite your advice, I was unable to resolve. Could you please take a look at my file? it took me two hours to do it, it would be disastrous if I couldn’t get it back. Do I have to attach the entire file folder or is the mlt file enough? Thanks in advance.
4- imtro cima.mlt (245.5 KB)

There is a blank in you file according to MLT Check here:-




Sorry the analyzer tool does not really help much, and it is not made by the Shotcut developers. The latest version of Shotcut will ignore such “blanks” but you might see instead “INVALID” in the video. At least when it does, you can see the time code and go to that place in the timeline to fix it. On V2 at 00:16:44:12 you have a transition next to a blank area. I think that transition is the problem and should be removed.

I digress purely for interest but when I delete that transition (the INVALID does indeed disappear) but if I CTRL-Z, the transition is reinstated but the INVALID error then disappears. I then save the MLT with a different name (in the hope of preserving details of the DEL/CTRL-Z action), to make a file comparison but they’re identical.

Is there any additional logic on the DEL/CTRL-Z (other than the action to delete and reinstate (CTRL-Z))?

Had same problem but came up with an alternative solution that seems to have worked as I noticed all of my missing files were .bmp:

  1. Create a blank bitmap (.bmp)
  2. navigate to the folder indicated in the warning message (mine was in appdata so had to enable hidden folders)
  3. Save blank bitmap in folder
  4. rename bitmap to whatever name is displayed in the warning message

This allowed me to then reopen the project and export it with no problems that I have noticed.

Hope this helps.

1 Like