Mask from file does not retain the link to the file when saving and closing Shotcut

What is your operating system?

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
Testing a mask file in png format I found that every time I open the project in Shotcut, I have to link the PNG file again for it to work normally.

OS: Linux Mint 19.3 (Cinnamon)
Shotcut: 21.05.01

Happend also to me.
Haven’t tried yet with 21.05.18

Thanks for your report and clear instructions. This is fixed for the 21.08 release.

1 Like

I wonder if there is a way to work around this. I have a 2 hour movie finishing project stale because it’s been crafted with 26.06.29 so I can’t open it with previous versions and I realy need mask from file working. I looked for 21.08 into github and it isn’t there… so I’m helpless here. If someone could tip me a quick workaround I’d appreciate.

Unfortunately, I can not think of a way to work around this. You will just have to remember to re-select the file every time you open the project.

It has not been built yet.

You can try the daily experimental build. But it would be at your own risk. Be sure to backup your project file.

1 Like

I tried different things to avoid the tedium of adding each time the link to the mask file in each clip.
In my case, the mask file is the same PNG file, so I created a track and placed the clips with that filter on it. In theory, I would only have to do the operation of reassigning the mask file once.
The mask filter could be applied to the track and not on the clip.
However, because of the filter settings and also because of the length of the project (less than 15 minutes), it was faster for me to manually relink on each clip.
I was then tempted to export part of the project in lossless UtVideo format, then incorporate that clip into an earlier version of Shotcut and continue editing.
I’m not sure, but you can try to save a copy of that project (once the masks have been corrected). Then you can try to open that project with the previous stable version. The Time Remap filter is not compatible with this regression, but if you did not use this filter, maybe your project will work without problems.
Just be sure to work on the copy of the project, to avoid damaging your original project.

1 Like

Thank you for answering! It’s bad :frowning: but I can’t relink the mask files everytime I open the project, there are too many. I’m using mask from file to fix bad chromakey spots on hundreds of different takes, across many tracks for each scene on a total of 25 scenes on a 2 hour movie made exclusevely using Shotcut, so, that bug is on my way, It’s bad but I don’t care :wink: Shotcut is great! I also tried opening the files with latest stable, but it fails to fix the mlt file and it crashes almost every time while opening the mlt without fix (hit cancel when dialog prompts to fix project file). So, I’ll wait for 21.08. Thanks guys!

1 Like