LUTs "Open" location

Hello to all. :slight_smile:

Recently started using ShotCut, congrats to the very cool project!
I tried to find a similar question without success, so:

When I use LUTs, I browse a file. If I would like to chose another one, when I click “Open” it’s always the default location.
In my case it’s / directory, so basically root folder of the drive.
Would be really nice if it saves the last path when browsing more than once so switching between LUTs will be much easier.
Yes, I can move my LUT files there, but it’s kinda unusual (it’s not even my /home) and there are many folders etc.

For the record, I’m using Linux Mint, so not sure if behaves like this on other OS.

Is there a solution I don’t know about, or someone else recognizing this as an issue?

Thanks!

Hi :slightly_smiling_face:!

That seems really unusual. I tested it with Windows and it opened the last directory, so after choosing a LUT it will open the same directory.

Someone who uses Linux Mint (or perhaps a Linux distribution in general) has to test this behaviour.

So I cannot help you, I am afraid.

It tries to open to the last filesystem path where something was opened (or ~/Videos by default), but this might be a bug with Qt Quick’s file dialog on Linux. What is your Linux app format (AppImage, snap, FlatPak, distro package)?
You do not need to move your LUTs to /; you need to navigate to where they are located.

Thank you for the replies.
I installed it via Software Manager and now when I checked, it says “Flatpak”, version 19.06.15.
Mint 19.1, all up to date. Machine is Ryzen 1700 and 1070ti.

I’m not familiar with Qt packages, but when I tried to see some versions it is pretty strange.
qtdiag (the command exists on autocomplete) output is:
qtdiag: could not find a Qt installation of ‘’

qmake -v is returning:
QMake version 3.1
Using Qt version 5.9.5 in /usr/lib/x86_64-linux-gnu

Maybe something related to these packages?
Btw tried to remove and install again ShotCut, same problem.

Thanks for your help!

No, Flatpak does not use your system packages. That is the whole idea of Flatpak. Within Shotcut, you can choose Help > About Qt to see the Qt version.

I just had a chance to test it with the flatpak (as well as the appimage, snap, and portable archive) and it is working for me. My Ubuntu 18.04 system has Flatpak 1.4.0.

This topic was automatically closed after 90 days. New replies are no longer allowed.