LUT filter not working

What is your operating system?
Windows 10 64

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.09.20, (shotcut-win64-210920)

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
The problem seems to be in the characters set in the path of the LUTs files:

Yes, I can repeat the problem:

  • I load an image, any image, to the Timeline

  • Select the image in the Timeline

  • Add LUT 3D filter

  • Open ANY lut file from this path (notice the “é” in it):
    C:\Users\José\Videos\Shotcut\Pruebas LUTs
    there is NO change in the image colors.

  • If I copy the LUT folder to the following path:
    It works perfectly!

I imagined it was the character set as I looked in the release notes and found there was a similar problem fixed (!) in Release 20.02.17:
_ * Fixed using the LUT (3D) filter with file with extended characters in its file path on Windows._

I can confirm this.
Windows 10, 64 bit.

Did not test any other letters.

This report might be related:

This report is different.

Same LUT file in 2 different folders.

Doesn’t work in a José named folder
I only tested with the one character. I did not do any further testing.
English (United States) language setting in Shotcut.

Does work in a different named folder without the acute accent.

So there is no fix/solution right?

This one is different.

Same LUT file in 2 different folders.

So you will not know which one is real then?

I was responding to @Austin . I edited my response so I was more clear.

I have no idea about the fix.
The workaround is to not to use the e with the acute accent in a folder name.
It’s the path to the LUT is not recognizing because of the acute accent above the e.

It is not just the acute accent over the e.

I’ve tested paths with acute accent above any vowel and neither work.

Also the other accents - à, ă, â, ä, ñ - prevents it to work.

I am using a Spanish keyboard configuration ESP

I only tested with the one character. I did not do any further testing.
I only tested with English (United States) language setting in Shotcut.


As subj says: LUT filter doesn’t apply if the lut file is located on the system path, which contains cyrillic characters.

In my example on video I use same *.cube file (black and white profile), but with a different sys paths.

Tested on v21.09.20 and v21.08.29 (both win7 x64).


PS: ‘Відео’ for fast test :slight_smile:

Probably the same bug outlined here:

I reproduce this in the release build but not in my development build, which is probably why I claimed it was fixed. It is rare that this happens but sometimes does. That’s because my development system was running a newer version of FFmpeg. Since I have upgraded FFmpeg for the next version 21.10 (now in beta testing), this is fixed and working.

1 Like