LUT file support

MLT supports libavfilter, which includes a 3D LUT filter:

For file formats, it supports .dat, .3dl, .cube, and .m3d. I just tested it and it works: $ ./melt ~/Videos/example/wildlife.avi -attach avfilter.lut3d av.file=/c/Users/ddennedy/Download s/Tom_Majerski__Tcolor_BMCC_v1_7.cube -consumer xml:/i/3dlut.mlt

Loading 3lut.mlt into Shotcut loads as a virtual clip. Easy to make a UI for this. See the “Frontend” section of this page:

The easiest way to develop it is use your existing Shotcut install, go to share/shotcut/qml/filters/. Copy an existing filter’s folder and rename things. Since this needs a file name, I suggest to copy the “stabilize” or “webvfx” folder to get an example that has a file field.

Umm, this is one of those awkward moments when someone just went to a lot of trouble to help you and you have almost no idea what they are talking about:

For example, I don’t know what this is:
$ ./melt ~/Videos/example/wildlife.avi -attach avfilter.lut3d av.file=/c/Users/ddennedy/Download s/Tom_Majerski__Tcolor_BMCC_v1_7.cube -consumer xml:/i/3dlut.mlt

Is this a command line to open shot cut with a the filter?

I also don’t know what a virtual clip is. Maybe when I have used it a little longer, I’ll be able to do this. Either way thanks for responding and going to the effort of trying it.

I know what you are talking about. I am just saying that the engine of Shotcut - FFmpeg and MLT - already has support for a 3D LUT, and we just need to add a UI element in the Shotcut to expose it. I do not expect you to be able to run those commands and do all that. Those are just notes and evidence of my research findings. Of course, a very advanced user could follow those steps and be up and using LUTs today.

1 Like

Ok, thanks, glad to hear that it’s something that’s easy to implement when the time is right.

Video filter “LUT (3D)” was added for the next version 16.10 due tomorrow.


Very cool, and a good timing too. :slight_smile: The Magic Lantern guys are just about to figure out how to shoot with LUTs in the Canon DSLRs:
So you can shoot with a flat LUT and color correct with a LUT, which corrects the image, but preserves the extra data(though you might need 10 bit for that).

1 Like

I tried the new features, finding online a 3D LUT (.cube) and I have a black image, applying it. Is it, specific to me?

As I understand, there are a bit different formats of 3D LUTs specific depending on software.
For example, LUTCalc ( offers several types of output LUT file formats. Will try with new Shotcut some today as well.

Thanks @Laccolith !
I’m interessed if you could share one that works OK. I’ve a Panasonic M4/3 camera.
I’d found some 1D Lut and of course it didn’t work, but I’ve try 3D LUT (.cube) & didn’t work either…

I found that Kodak 3D and Lustre 3D *.3dl LUT files with 17x17x17 size work well. Sizes 33x33x33 and 65x65x65 produce wrong colors (bluish-green solarized psychodelic). Also better to set "Tetra"interpolation in filter settings as this produce smoother color gradations.

All *.cube 3D LUT files generated with LUTCalc with any settings display blank screen.

1 Like

I only tested with downloadable LUTs provided by Tom Majerski. The core of this filter is provided by FFmpeg libavfilter. You can see from link to the docs what formats it supports. I enforce these formats through the file dialog’s file-filters mechanism. You can search the web for “ffmpeg lut3d” plus whatever other keywords you need to learn about any other constraints, limitations, or problems.

1 Like

I tried with LUTCalc and I even have solarized images with 17x17x17 too.
Will dig this week-end & will try Toms’ Luts too.

On Win 7, I tested a bunch of 3D Luts and still blacks screen except the LutCalcOne with 17 17 17 but solarized result…

We figured out that there is a bug in locales that use a comma for the decimal point because the numeric data in some of these file formats is text and use a period:

A workaround might be to convert the file to use commas with a text editor.

1 Like

Cool !
I’ll wait till the MLT change is pushed to Shotcut. No problem!

Hi, relatively new to Shotcut, very nice program!

What I was going to mention is on Windows would it be possible for the filter to remember the last directory of a opened cube file? at the moment it pops back to (in my case) C:\Program Files\Shotcut which I end up having to browser back to the previous location where the cubes are stored. Obviously I can bookmark the folder alternatively. Only a suggestion.


First, I agree with @PuG. While trying various LUTs, it can be realy quicker…

Except that, I just want to report that I still have the Black screen while updating to Nov version.
I’m on Win7 64bits. French language on the system. Doesn’t work with Eng on shotcut.
I’ll try to re install Shotcut resetting prefs. Then I’ll try changing Windows language.
I’ll come back here maybe tonight or tomorrow !

Regarding the dialog starting directory. The code actually does try to save and use the path, but it simply is not working due seemingly due to a bug in a library we are using.

And yes, I just confirmed myself that the LUT fix for 16.11 is not working on Windows.

I found the cause of the problem on Windows for next release.


I use the newest version of Shotcut and I still have a black image when applying a Canon Log to WideDR LUT. I run Shotcut under Windows 10 64 Bit.