LUT file support

I tried with LUTCalc and I even have solarized images with 17x17x17 too.
Will dig this week-end & will try Toms’ Luts too.

On Win 7, I tested a bunch of 3D Luts and still blacks screen except the LutCalcOne with 17 17 17 but solarized result…

We figured out that there is a bug in locales that use a comma for the decimal point because the numeric data in some of these file formats is text and use a period:

A workaround might be to convert the file to use commas with a text editor.

1 Like

Cool !
I’ll wait till the MLT change is pushed to Shotcut. No problem!

Hi, relatively new to Shotcut, very nice program!

What I was going to mention is on Windows would it be possible for the filter to remember the last directory of a opened cube file? at the moment it pops back to (in my case) C:\Program Files\Shotcut which I end up having to browser back to the previous location where the cubes are stored. Obviously I can bookmark the folder alternatively. Only a suggestion.


First, I agree with @PuG. While trying various LUTs, it can be realy quicker…

Except that, I just want to report that I still have the Black screen while updating to Nov version.
I’m on Win7 64bits. French language on the system. Doesn’t work with Eng on shotcut.
I’ll try to re install Shotcut resetting prefs. Then I’ll try changing Windows language.
I’ll come back here maybe tonight or tomorrow !

Regarding the dialog starting directory. The code actually does try to save and use the path, but it simply is not working due seemingly due to a bug in a library we are using.

And yes, I just confirmed myself that the LUT fix for 16.11 is not working on Windows.

I found the cause of the problem on Windows for next release.


I use the newest version of Shotcut and I still have a black image when applying a Canon Log to WideDR LUT. I run Shotcut under Windows 10 64 Bit.

LUT filter works for me in v17.06 with both locales using comma and period as decimal point. Of course, I do not have your LUT; I am using Tom_Majerski__Tcolor_BMCC_v1_7.cube. Maybe you should download it and try it.

Today I retried and I noticed that in Shotcut, LUTs are integrated, as the clips I am using from a colleagues Canon 1D C shot in C-Log already display color corrected automatically! When I add the 3D LUT filter and click the checkbox besides it, the footage is not color corrected anymore. Loading the Canon C-Log to WideDR LUT results in a black image, so applying the LUT manually still does not work.

Now the question that remains is, if the LUT that is automatically applied to Canon 1D C C-Log footage is a generic one or if the real, original one directly from Canon is implemented in the Shotcut program?

I don’t think the LUT can be automatically applied…

I just saw tht this LUT crashes Shotcut. Can someone test it for me please? (141.5 KB)
Thanks !

I ordered a Canon 5D Mark IV, which also offers a C-Log upgrade. Will this upgrade be compatible with Shotcut from the get go or do I need to wait for an update? The reasoning is that I need to transcode the footage anyway to play smoothly in then ProRes, so I can also take advantage of C-Log’s higher dynamic range at the same time.

That LUT is working for me on Shotcut 17.06 on Windows 10 using region settings with both period and comma as decimal point, GPU Processing not enabled.

I do not have much experience with camera log and raw formats, but I am fairly certain FFmpeg, which we are using, does not automatically convert that.

I’ll try again and report. Maybe I’ll grab a log (but I’m going to vacation soon, maybe it will be in september…).

Sorry to bump this older thread, but i have this issue also.
All of these produce black screen: (note i had to rename .CUBE to .cube)

Could it be the file you are applying the .cube lut to, every .cube I tried(many just see the look) on my pro res 4.2.2 10 bit works fine ( BMPCC) also on GH4 files and XAVCS never had any lut fail.

videos taken by DJI Phantom 4 in DLog. Many other .cube files work, but these go black.
Shotcut 18.01.02
Linux 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64 GNU/Linux

maybe i don’t know what i’m doing, LUT’s are new to me.