Linux: menu->File->open other... "capture file"

I was able to capture my video from my analogue video camera (video 8 tape from 1987) with my video grabber and Shotcut in Windows 10.

But I want to be able to make the same in Linux. In Linux I use Shotcut Flatpack 21.05.18 . Shotcut works fine in Linux, when I edit existing videos.

But I was not able to grab my analogue video from the camera with menu->file->open other…

Here is what I get, when I try it:

What Do I have to do, to get what I want?
(Please note: I was able to get the video with VLC in Linux.)

Here are some data from my terminal:
$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 534d:0021
Bus 003 Device 003: ID 046d:c045 Logitech, Inc. Optical Mouse
Bus 003 Device 002: ID 04ca:007d Lite-On Technology Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

→ Bus 003 Device 006: ID 534d:0021 is the usb-grabber. It’s an MS2106 Easycap I guess.

$ arecord -l
**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 1: PCH [HDA Intel PCH], Gerät 0: ALC221 Analog [ALC221 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 1: PCH [HDA Intel PCH], Gerät 2: ALC221 Alt Analog [ALC221 Alt Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: USB20 [AV TO USB2.0], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

Please let me know, if you need the output of “dmesg”. It’s very long.

Would appreciate some help. What do I have to type in to get the video? Thank you.

Hello: In principle it didn’t work for me either on Linux Ubuntu Studio.
Then I initialized the device via VLC (Open capture device-Ctrl + C) - Video device name: /dev/video0
During that time I have Shotcut open.

I close VLC and in Shotcut, I choose (open other- Video4Linux- device /dev/video0) and it appears in the preview window without problems.

Apparently, Shotcut somehow doesn’t initialize the device.
I don’t know if this will help. I tried initialising the device with Vokoscreen NG and it also worked.
I don’t know how it works in the Flatpack versions (I’m testing with Snap), but I remember that some things are different between the two packages. For example: With Snap, I can’t access the folder where I export the video from the export context menu in Shotcut. Maybe this can influence this. (I don’t know).
I hope this “trick” works for you.

Thank you. But this seems not to work.

I don’t know how to work with commands in Linux so I can only help in a limited way.
If you were able to open the grabber from VLC you can test which device you are using.

In my case VLC works with Video0 and Video2, but not with Video1 or Video3. I was testing devices.
So my silly idea is to test from VLC until you know which device works and then type that name in Shotcut (Video1, Video2, etc).
I just tested by typing in the device field Video2 (which worked in VLC) and it works in Shotcut too (as it did before with Video0).

As I have only tried this with the flatpack version, I now have installed the normal version from the package manager. Version 20.06.02 .

It’s the same. It does not work:

I am sorry I cannot help you better. :pensive:
I hope someone can help you with this issue.
In the meantime, I did a quick search and found something related to the USB grabber in Linux.
Easycap - LinuxTVWiki
Talk:Easycap - LinuxTVWiki

I have the one with the “Macro Silicon M2106 chip” (USB ID 534d:0021).

This topic was automatically closed after 90 days. New replies are no longer allowed.