Lagging when moving playhead on the timeline

Hi, I have just bought a new laptop Lenovo Legion 5, Windows 10 64bit, the specs, a Ryzen 7 5800h 8core, 16GB Ram, RTX 3060 graphics card. These are the minimum requirements as stated for 4K editing. However, when I drag the playhead along the timeline there is a delay and a bigger delay going backwards. I am editing 4K 25p from an iphone. Is this normal or should it be smooth? Thanks.

Try enabling Settings → Proxy, It will help a lot

Also, as the video is from a mobile phone, there is a good chance it is Variable Frame Rate (VFR) rather than constant. You can check in shotcut by looking at its properties. These videos should be converted to edit-friendly.

1 Like

Hi TimLau, thanks for the reply. That does work, I clicked on settings > proxy >use proxy and it automatically turns each clip I loaded into a proxy. Amazing so simple. I assume when I render the clip it will return to its original format, will it? Many thanks Roger

Hi Elusien, thanks for the reply, when I checked the frame rate in properties it said 25p not VFR. TimLau has the solution turn the clips into proxys. Thanks Roger.

Hi TimLau, thanks for the reply. I think I posted my original reply to Elusian by mistake. That does work, I clicked on settings > proxy >use proxy and it automatically turns each clip I loaded into a proxy. Amazing so simple. I assume when I render the clip it will return to its original format, will it? Many thanks Roger

Yes, when you render (export) your video, the original 4K footage will be used and you will get the full 4K quality

Hi, I think I spoke too soon. I have applied some editing to the clip, trimmed it, zoomed in a little and added a little sharpening, now moving the playhead along the timeline is worse than before.

I think I have paid a lot of money for a computer that will not edit 4k smoothly in shotcut or am I doing something wrong?

Make sure preview Scaling and Realtime (frame dropping) are enabled

image

image

Hi PaulusMaximus, the Real Time (Frame Dropping) was ticked but the Preview Scaling was set to None, so I changed it to 360p. It did make it better but still not good enough.
Is there anything else that can be done or is it just that my laptop specs are not good enough.

Try putting your clip on the timeline, just let it sit there for a few minutes or so before you do anything. I’m not sure if it still applies but Shotcut had to build the audio waveforms when placing clips on the timeline and I think sqlite used to be a bottleneck for that.

Try it ticked and unticked. For many people, Shotcut is more responsive when unticked because more threads can be used in that mode.

Also, for fixed zoom amounts, “Crop: Source” is a lower-CPU way of zooming in than using Size, Position, & Rotate.

Hi PaulusMaximus, I left the clip on the timeline for five minutes, no difference.
Hi Austin, I tried it ticked and unticked, very little difference but the zoom with “Crop: Source” made it better, but overall still disappointing.
I think the only thing open to me is to increase the RAM. However, I am reluctant to open up a new laptop buy new Ram then find it still isn’t good enough.
A dilemma !!!

What have you got running on the laptop as well? Browser OFF. I reboot mine before doing any editing - or at least check “TASK MANAGER” to see what is running - often Microsoft EDGE leaves some “bits” running which I end. Also, check that “UPDATES” aren’t trying to load - Microsoft seems to have them check and upload at the worst time - you can pause them to make sure, just don’t forget to switch them back on again.

Hi, Alanclarkeau, Updates are done, in the task manager everything is off except my antivirus. I don’t know how to switch it off. Maybe tomorrow I’ll uninstall it and try. However, I assume everybody has antivirus so this shouldn’t be a problem.
I’m still considering increasing the RAM.