Is this a Timeline Bug?

If I load a clip onto a track and then split it up into say four parts leaving a gap in between each part the Skip to previous point/next point buttons will take me from the start of a segment to the end of the segment, then if I press next again it will take me through the gap to the start of the next segment.

Where this behaviour differs is if you are on the last segment in which case it won’t take you to the end of that segment but the end of the time line.

Is this a bug?

I would have expected that I would have ended up at the end of the segment after pressing next and then if I pressed next again would have ended up at the end of the timeline.

The end of the last segment is the end of the timeline. It sounds like you somehow caused the timeline duration to exceed the end of the last segment. It sounds like you have a bug where you are able to make the timeline longer than the end of the last clip. I have seen that but I do not know how to reproduce it. Steps are welcome.

Okay i start shot cut.
I select a non broadcast 1080 mode under settings video mode.
I then go file open and select the video to edit, in this case it’s an .mkv file
I pause the playback in the preview window
Select properties->audio and make sure that the audio is using track 2 ( there are three tracks )
Then I select filters from the menu, click on the +, click on crop and enter the value 240 in left and right - you can see the preview change in size but it still shows black borders on the left and right.
Then I select settings->video mode->automatic at this point the preview window changes again and the black bars go away.
I now drag the preview video down and get shot cut to automatically create a timeline.
At this point the edit head is not at the end of the video but at the end of the timeline Shot cut created and it’s length was 59:07:06 whereas the video length was 45:12:05. At this point there is only one clip.

Please let me know if you are able to reproduce this.

** extra credit **
I’ve found the time line only seems to get extended if I select video mode->automatic, if I reproduce all the steps without doing this then the timeline matches the clip but as soon as I do this and drag it down the timeline length is altered.

It is not necessary to use a clip multiple audio tracks or use the crop filter. I reproduced it by changing from an explicit Video Mode that is a higher frame rate than the clip to the Automatic mode. There is a bug with the clip duration changing when making this change. yes, I know you are trying to workaround another bug I do not reproduce. Patches are welcome.

The simple workaround for this bug is to simply trim out the extra duration that was introduced.

Yes that’s what I just found as well, I was listing all my steps for recreation purposes.

Patches are welcome - I have not looked at the source but I bet it’s either C or C++, I have a little ability in C# and VB.