Is Shotcut broken now?

Thanks for your time, and thank you for your answers!

I did not use the preview settings, since my source material was pretty low res, I will use it anyway in the future.

The appimage idea is a good one, ill try that.
I will test a few options and see where it leads me.
So far, thanks for your ideas!

I did not reproduce it.

[Info ] Application::Application install dir = “/usr/bin”

Not one of my builds and thereby not supported by us.

Well, its in the official repos for a whole distribution and its the newest version and you are not supporting it? Ok, in a way I understand, but almost all users of this distribution will be using it the way I do. But, whatever.

I just downloaded the portable version from Shotcut - Download so it’s not a “support” issue anymore and guess what?

Same crash.

./shotcut: line 21: 222691 Segmentation fault (core dumped) bin/shotcut “$@”

Now, this is actually a version you support. So, what now? :wink:

I am a Linux user for over 23 years. Please understand that there are very many distributions, and there are very few technical people helping this project. The two developers in our project are not going to run a bunch of distros and verify every build of every version. Do you not recognize fragmentation, why companies are reluctant to support Linux, and why app bundles are a thing now?

Now we are a step closer to being on the same page. But also you can try to debug it yourself since I don’t know how to since I did not reproduce it.

One thing I found in your project that might be a contributing factor is very odd project resolution and aspect ratio.
Screenshot from 2022-10-18 17-02-09

This suggests you were using Settings > Video Mode > Automatic, and the first clip you brought it is like this. The weird frame rate also suggests that first clip was variable frame rate, which is not safe for editing. We try to show a warning for that, but it is not perfectly detectable.

I see in your log that you are using proxy and preview scaling. You can try turning those off to see if it makes a difference.

In addition, I just remembered this bug since you said it is drag-n-drop to the timeline. You can try using the timeline toolbar buttons or shortcut instead to see if the problem is specific to drag-n-drop:

1 Like

Do you not recognize fragmentation, why companies are reluctant to support Linux, and why app bundles are a thing now?

Yeah, I totally understand. In the end, I am just grateful that software like shotcut even exists. And I am very grateful that people like you care about it and develop it. So, the biggest point I want to point out is: a big thank you for all that.

Also, Bugs are normal. Software development can be hard, and squashing bugs even harder.

I took the time and converted all source material to constant framerates/different resolutions/etc. and tested with them: same crash behaviour. So, it does not seem to be the source material.

My workaround was to copy directly into the timeline from another open shotcut instance, that worked out well for me.
But also from the bug report you mentioned:
" Use “Add Selected to the Timeline” from the Playlist menu to avoid dragging and dropping."
works fine as a workaround.

Funny thing: when you add to the playlist and drag it from there, there is no crash. Just when you drag it from the main editing area(or player), but I guess you know what I mean.

So, that workarounds are really ok for me and after reading the bugreport you linked, it seems to me that it could be the same issue.

Anyway, thank you for your time and contribution!

I really love shotcut and just wanted to contribute in a way, maybe I could have done a lot better. (still learning english ;))

I am having exactly the same problem that was described at the beginning of this thread. Like many of you, I have been using Shortcut very successfully for years on my current hardware - but I have never seen odd performance problems with the UI until now.

My i7-5820k (6 cores, 12 threads clocked at 3.3GHZ), 32GB, with 24TB of 7200rpm disk storage (with distributed paging files across all spinning disk drives), Windows system recently upgraded itself from 10 Pro to 11 Pro around the same time Shortcut was upgraded to the most current version (22.10.25). I have seen no adverse reactions whatsoever from any other applications, including many heavy duty games under Windows 11.

In Shortcut once I try to load an input video file, the Shortcut UI’s performance becomes so sluggish that it is practically unusable - often taking 2 or 3 minutes between each fairly trivial interaction with the UI In the Task Manager I see “melt.exe” consuming 60% to 90% of the CPU resources, using a couple of gigabytes of memory, and doing 3 to 4 MB/s of disk activity. I think it’s doing this even before I have created any background job to process the input files.

I’ve tried turning the hardware encoder on and off and de-installing/re-installing Shortcut with no effect. I’m not sure if the particular input files (created by a standalone hardware encoder or a commercial video editing program, “PowerDirector” that I used to use which are usually quite a bit larger than the files I create with Shortcut) may be triggering the problem too. The input files I’ve been seeing these problems with recently are are roughly 4 to 15GB in size. It should also be noted that even when the Shortcut UI is being very, very unresponsive, any other application I bounce back to on the desktop is running fine, with no performance issues at all.

I’ll keep playing with it to see if I can figure anything out that effects this problem, but when this problem is occurring - it makes using Shortcut totally painful! Thanks in advance for any further thoughts or suggestions!

Well there you go. That only runs for jobs, and it is a job from a previous session. You should kill it if you do not need it anymore, or wait for it to complete before using Shotcut.

Thanks for the explanation, but I’ve run tons of jobs in Shortcut for years and never seen the UI get completely stalled like this. I’ve killed “melt.exe” if I see it running when I haven’t queued up a displayed job in Shortcut, and it makes no difference. Literally, to load a video file, move it to the timeline, and then export it as a new file (at the same 1920x1080 resolution) can take 10 to 15 minutes - if it can complete each of those steps at all. I’ve seen Shortcut get so sluggish that Windows starts saying it’s unresponsive and I eventually have to kill the process.

It even takes several minutes to bring up and fully render all the portions of the load and save menus too. Once Shortcut is working on a job it has queued up, consuming about 80% to 100% of the CPU resources in the process - I can even load up and play Destiny 2 with no observable slowness or side effects at all (because Shortcut is running at it’s “low” priority I presume) - so my system hardware is performing. perfectly as expected.

The CPU and GPU aren’t thermal throttling either, peaking out at just over 50C each - even after running 100% load on all cores (video rendering historically) for over an hour.

As mentioned above, I was suspicious that something in the exact format of the MP4 files I’m importing is causing something in Shortcut’s UI to go into a tail spin. Something is different when the input file is 15GB, yet the output file that Shortcut outputs (with the same resolution and frame rate) is only 1.8GB - with absolutely no degradation in observable quality. However a brief test shows that even if I’m importing a much smaller file, one that was actually rendered by Shortcut - the UI still slows down tremendously once the file is selected.

I’ll still keep messing with it, to see what else I can figure out. Thanks again for your thoughts!

When Windows users have this issue, there are some common themes:

  • Some antivirus program is getting in the way. Try turning them off as a test
  • Some obscure security setting needs to be changed (like ASLR)
  • They are storing their media files on some remote or removable disk

I hope you are able to unlock your problem and share the solution with us.

Thanks for your suggestions!

Haven’t tried turning off my Norton anti-virus, but I’ve been running it as long as I’ve been using Shortcut so it’d be surprising if that’s an issue.

In the Windows advanced security settings ASLR is off (and the fine print makes it sound pretty scary to turn on), where as DEP and CFG are both on. I could not turn on the Core Isolation Memory Integrity setting because most of the drivers that run my motherboard audio and gaming devices like my Logitech headset aren’t blessed enough by Microsoft Don’t really see how that would effect the performance of the Shortcut UI going into the toilet as much as out and out crashes anyway?

I have the general Windows performance settings set to “Programs” rather than “Background: tasks”, which seems to have no impact whatsoever on all the background tasks that I do run on this system. (It runs a media server, home security camera hub, the online backup client, and several web servers on my local network - all without missing a beat even when the system is running flat out). None of that environment has changed for years.

All the media files I’m working with as well as Shortcut’s install and temp working folder are on full speed SATA-3 hard drives which are working perfectly for any other processes trying to use them.

Someone way above in this thread suggested going back to an older version of Shortcut, which I may try - even though I’d be pretty surprised if that’ll actually help. It seems unlikely that Shortcut’s UI thread is getting starved for system resources (given that anything else, including a huge game, is able to run just fine). I wish I could see what the UI is actually doing and waiting on, or is it just running at a low priority as the job tasks do, that that’s keeping it from getting enough? I’ll keep playing with it and keep you posted - thanks again for your help!

Does Norton use more, less, or the same amount of memory when using Shotcut?
Have you white-listed Shotcut with Norton?

Thanks for your reply!

None of the Norton processes seem to use any more memory or CPU resources when Shortcut is running. The only program specific white-lists I can find only relate to communication firewall rules, not anything to do with the anti-virus or just running the program. Norton does accept Shortcut’s install program as a “trusted application” based on automatic customer feedback.

I looked at the Windows compatibility settings for Shortcut, but there was nothing there that looked reasonable to try. I sure don’t want it, or anything, to ever run in Windows 8 compatibility mode!

This evening, I was able to process a small file with Shortcut just fine - but like I’ve been seeing it totally bogged down and the UI pretty much stopped responding once I loaded a 5GB input file.

All of my 4 hard drives are formatted with NTFS, using different allocation unit sizes depending on their total size and what’s on them. I just replaced one of the 8TB drives (the one where most of my videos are stored) with a new one, because the old one had been spinning for over 30,000 hours and its brother drive failed a couple of months ago. I formatted the new drive with a 256kb allocation unit, while my other 8TB drive was formatted with a 128kb unit size. I copied one of the input files from the one with the big allocation unit to the smaller one, to see if Shortcut worked better with it on that drive. Well, not really - it still ran through the steps I did on the UI like a stuck pig, much slower between mouse clicks than I would normally expect - so no conclusive differences there.

I may try to download another free, open source video editor to see if it can process the same input files better than Shortcut is currently able to do. Problem is that when I was looking around and found Shortcut several years ago, most of the other ones sucked by comparison. I’ll look around again but If I’m desperate I may try the bloatware one that Microsoft shipped with Windows 11, ClipChamp, which I deleted but wouldn’t expect too much from…

I’ll keep this thread posted, and again thanks for your help!

I tried installing an older version of Shortcut, 22.06.23 just to see if it would behave any differently with the UI hangs, but it did not. As soon as I tried to load a 15GB input file, the UI totally hung and never completed that action. I saw its memory use as reported by the Windows task manager jump to over 21GB - making the total system memory in use go up from about 23% to 97%.

So I know I was probably running version 22.06.23 successfully under Windows 10 for quite a while, so this again focuses attention on what could have changed to impact its performance in the Windows 11 environment. Not clear what could be the direct cause, since every other application I had running before the Windows 11 upgrade is still working and performing normally.

I re-installed Shortcut’s latest 22.10.25 version and will continue to try to understand what’s going on with under Windows 11.

Well, sometimes that does happen when running an upgrade, as opposed to a clean install (which I understand is impractical as a first port of call, and that can even be the same in a Linux environment when upgrading).

A couple more options. Try creating a new user profile, only install Shotcut on that and test your 5GB file locally and see what happens.

I don’t work with WIndows much anymore these days since my tech days are over, but take a look at your page file settings also (since your RAM gets gobbled up rather quickly from what I read). Maybe try System managed instead of automatic, and then if that doesn’t work go with a custom size. I doubt this will help but it’s an easy and quick change. I’d test all this on the new profile.

Good luck mate.

Thanks for your thoughts!

I reconfigured my page files (swap space) after the upgrade to Windows 11, because it got changed to just use my OS SSD when Windows 11 was installed. (I wasn’t really happy with that, because I didn’t want to wear out my SSD with all the paging, that could just as well be being done on all the hard drives I have). I did this after observing the Shortcut UI problems, which behave the same way both before and after any reconfiguration of the system’s paging space.

So now I have page files (system managed size - generally about 5GB each) on all four of my hard drives, which is better because it distributes the load across more devices - just as we learned decades ago on old mainframe computer systems. I have no indication that this isn’t working well - as pretty much everything else and the system itself are running great, with excellent performance and responsiveness except for Shortcut.

When Shortcut’s UI drops into its super, super slow mode (pretty much always after loading an input file bigger than a hundred or so megabytes), the working set size gets larger that expected - noticeably larger than the total size of the input video (like 21GB if a 15GB file is loaded). Still smaller than my main memory size (32GB) though, so most of it shouldn’t be being dumped into paging files.

The fact that the Shortcut UI gets so super slow and hangs so much may be related to how work is being assigned across the threads that Shortcut is using? There are plenty of CPU cycles to do everything that Shortcut should be doing just fine - but the UI runs like a lead brick when ever a moderate sized input file is loaded. (Even before any jobs are running either). Generally, lots of heavy duty work shouldn’t be being done in the same thread that is running the UI - but from these symptoms, it seems like that may not be being followed?

Why the heck the transition from Windows 10 to 11 should have anything to do with this is another question that I’m still puzzling over. …

Shotcut! Shotcut! Shotcut!

So you tried a new profile?

Thanks for your reply! If by profile you mean a different preset in Shortcut, yeah I’ve tried a few different ones but have seen no difference in the UI hanging using any of them.

I did not try setting up a new userid in Windows (as my understanding is that each requires its own “Microsoft account” under Windows 11, which I’d rather not fight with). I can’t imagine how that would behave any differently anyway, especially since every service my system provides now (everything from FTP, web, media, and home security camera hub) are all run from perfectly from my main userid - while I’m off playing demanding AAA game titles to boot.

I just tried loading a relatively small 444MB input MP4 file and watched the UI instantly hang and the Shortcut process going nuts grabbing system memory. (The performance monitor graph It was climbing at about a 30 degree angle and was just passing 7GB (and still climbing) when I killed the process from the task manager. Instantly the system memory use dropped back to a total of about 9GB total for all the other running processes. I/O activity on the hard disks where the system’s paging files are located only hit 1% on one of the four drives the whole time.

Most of the input files I normally process were created as 1920x1080 screen grabs using OBS studio. These files are relatively efficient in their size (not huge) while providing excellent resolution, color depth, and smoothness (usually about 30fps).

I’m wondering what would cause Shortcut to want to consume so much memory, that quickly - even before any output job had been started? (No old jobs were restarted in the background either from what I can tell). From the totally frozen behavior of the Shortcut UI, it seems likely that what ever was consuming the memory was being done from its thread within Shortcut. The system’s CPU metrics never showed more than about a 20% load and any other application I accessed from the desktop continued to run perfectly, with no hangs or unexpected delays, the whole time Shortcut was locked up.

So the more I look at this, the more puzzled I am about what the heck is going on. It never did this while I was running Windows 10, even though I processed some much, much larger input file with no sweat - and it certinally should have under Windows 10 if it was consuming system memory like this is now. I guess I need to try to find another open source video editor to try, just to compare the measurable performance for comparison. (I don’t trust the bloatware one Microsoft stuck a “free trial” for in Windows 11, that’s for sure)!

O.K., I just downloaded, installed, and tried to use the OpenShot video editor for a comparative sample. I then combined 4 separate input video files (1920x1080 at 30fps, about 150MB in size each) into a single file rendered at the same resolution at 50fps. The whole process ran smoothly to completion using about 30% CPU (across all cores and virtual threads I guess) and consuming about 1.1GB of system memory the whole time. (No detectable paging activity seen at all). The output file was just over 2GB in size, probably because of the higher fps being output. The memory consumption was more in line with what I would expect, and have historically observed, Shortcut to be doing.

The OpenShot “simple” UI is just that, pretty simple. I had a hard time figuring out how to trim the input files as I merged them together, never finding any good way to move up and down the output timeline very well. As the output was processing, I spent some time reading the online user’s guide which explained that they expected individual input files to be split in the project workspace, rather than being edited once they had been added to the output timeline - which wasn’t what I was expecting…

So I’m still baffled about why the Shortcut UI is going into the weeds on me right now, to be sure!

Hello there,
I’m experiencing the same UI hang issues.
In my particular case looks like it started when Win10 upgraded its .NET Framework. Tried uninstalling it, but it seems not possible.
The only way to get a decent responsiveness is running Shotcut as administrator, but by doing so I can’t drag any files in the timeline anymore.

FYI, I do the same - I edit these in Shotcut under Windows 10 and Windows 11 and have no problem whatsoever with memory.

Since you have this problem with different versions of Shotcut it has to be a Windows 11 problem. I don’t suppose you’d consider doing a PC Reset (under SystemRestore?