Is composing tracks buggy ? whats the trigger?

hello all,

I had a similar problem posted here before, but there was no help or tips that could have helped me so far:

First I “only” had problems composing more then two tracks, all tracks above 3 were not mixing/composing
with tracks 1 and 2. somehow I was able to “fix” this with deleting tracks, undo deleting and then it somehow
worked as supposed.

Now everything looks fine, but after export only the top track (in my case 4) is beeing showed.
this now gets really annoying since I cant reproduce all the work that is done again.
so how do I fix this ?

seriously I had more problems with this tool and trying to fix them, then enjoying to work with it…

Yes, it was this post, right?

People have tried to help you. When asked for further information you couldn’t share because of company property. That’s fine, and we understand not everyone wants to share, if it’s company property or not.

My suggestion is, don’t use any company property, recreate what you have here, but use your own images. It could be as simple as taking a video of a grocery store parking lot, to people walking in a public park. Take a photo of a stop sign, etc. Take a screen shot of your timeline. Upload the saved mlt file.

This is my first time using more than 2 tracks. Everything seems normal to me.
Windows 10 Home
Shotcut 18.05.08

test61.mlt (7.2 KB)

Test video on YouTube:

I know ppl have been trying to help, but all the basics how to compose I think are abvious that I should know.
and if I tell that my tracks header look exactly like theyre looking like from someone else posted his.
I even posted a picture so it wont help if I do that again and explaining the problem again and again.

I really appreciate your and any other help but I can only repeat myself in this case ur picture does show exactly
how my tracks are looking like (just my content)…
as soon as a third track is added, its not mixing/composing the tracks anymore.

this problem is so fundamentaly breaking the softwares main usage so I think there must be more then
one person haveing this problem !?

what I can add is: I have the feeling that the “bug causing trigger” is saved within the project.
if I start something completly new it works “mostly” fine.
If I open the project it doenst work fine

How can we find it if the trigger is in the content you can’t share?

how do u wanna find the problem if I post a pic which is exactly the same like someone elses ??

its a video track and two or more transparent graphics, same settings like posted above…

and again, only the top track is appearing while its supposed to be composed with track two and one

In my picture, see where I have just V3 selected (you’ll see a red box)?
With V3 selected, go to Properties. I have Blend mode : Over
V2 Blend mode: Over
V1 Blend mode: Over
Never touched any of the composite buttons.
Added the video first, then added V2, V3 with PNG’s.
Size & Position filter for both V2 & V3. (not needed, but it’s what I used).

How do you have two V3 tracks?
Did you rename one of the tracks to V3?
I’ve never seen that before.
See how my tracks are labeled from the bottom to top, V1, V2, V3?

I tried ur suggestions blend mode over. it was actually already setup like this, for all tracks.
changing it didnt do anything…

regarding the tracks name: I had 4 tracks in there before deleting 1 and 2.
so 3 and 4 where left over. somehow when I added the top one it was named V3.
totally weird. I migtht have had the same thoughts like u that mixing the tracks numbers could cause
the problem, but I changed em and that didnt help neither

I’m looking at the mlt code, I don’t think it matters. It’s just a label for us to see on Shotcut for each track.

I’ve had compositing issues, but I haven’t asked about them because I haven’t been able to recreate them reliably. As you say, it seems to happen to a specific project.

One thing that I’ve read somewhere here on the forums is that moving/deleting tracks around can cause issues. I can say that since I have made an effort to never add or move a track, I have not noticed any non-reproducible compositing issues. When I add a track now, it’s there forever, which is inconvenient but seems to have prevented these types of problems.

Another thing that’s helped improve reliability, though I don’t think it will help with your compositing issues, is to delete Registry entries (Windows versions only). The easiest way to do this is to reinstall Shotcut using the installer and select “delete registry entries” or something like that (I’ve always done it through RegEdit).

One trick that seems to sometimes work is to throw a Rotate filter on a clip, which seems to help with some compositing weirdness. Though once again, I don’t think this will solve your particular problem; but it doesn’t hurt to give it a shot.

its so weird, I opened now like four projects. just adding a third track.
as soon as I do this it covers all other tracks, not composing.
I cant even do anything wrong. its just two clicks

When you add tracks, how do you add them? Keyboard command? Right-click and “Add video track?” Some other way?

right click on the track headers and the adding video track

Can you close the mtl and then use the Open “open mtl as a clip” to see if the tracks mixes normally.

PS : (just in cas, to be sure) on your screenshot, V4 is selected. Do you select project to play it? Or double clic on master?

@ Keno40
I opened one of my project where I had this problem first, it does not play like I want it.
the top track (no 3 covers everything black, even it is a transparent png24)

so it plays the “bug-version”

I’ve had this happen a few times and it has been directly related to adding/removing tracks. Most of my work involves multiple tracks - typically 6 or 7 video and 3 or 4 audio. I often have to insert and/or remove tracks to achieve the layered effects I need, especially now we have keyframes. I have noticed it in particular when using footage or overlays from 3rd party sources with varying resolutions and framerates. When I have had this happen I have simply deleted the clips on the tracks affected and reinstated them from the playlist which has usually restored visibility. I note that you have observed the same solution worked for you before. Obviously it can be laborious if you have multiple clips on the track, but it’s better than abandoning the project.
What I have also noticed is that on occasion, it has been a particular 3rd party image or clip that SC just “doesn’t like” in which case converting the clip to a different format or resolution or editing the image on my own software rather than using the original has allowed me to use it.

1 Like

“good” to hear someone else having this problem …

though I dont think its caused by the files.
somehow sometimes the same file works fine on the track composing perfect,
and in the next second it doesnt. I think its trigger based problem. like u said.

i would even go for deleting and adding to solve the problem but first: I cant delete
my main cutted video track, and second I got it for example working with delete and undo,*
but the export file shows still the bug version, which is not seen in the peview window/work area

I can now reproduce that its not bound to the “top” track, the bug is related to the “last” added track,
doenst matter if its on top or inbeetween.

It doesn’t happen to me often, but when it does I try the solutions I mention above…
First try removing the clips/images in reverse order then reinstating them. If that doesn’t work, I try to isolate the item causing the glitch and reprocess it. It rarely takes more than a few minutes. It has happened to me once that a clip I have previously used successfully on one project caused problems in another - I fail to understand why, but I had to just accept it and find a workaround.

So if you add one more track, an empty track, does the previous one become functional?