Interlacing

Shotcut not interlacing.

Video interlaced with Shotcut and later tested with idet

ffmpeg -i interlace.mp4  -filter:v idet  -frames:v 60  -an  -f rawvideo -y  nul

gives TFF:0 and BFF:0.

Either TFF or BFF should be non-zero.

Was the source progressive?

Please share:

  • The video mode selected in the Settings menu
  • The export settings you are using

Yes, the source is progressive.

In Shotcut,

"Scan mode is set to “Interlaced”

Frame rate is set to 29.97.0030

Field order: Top Field First

Interpolation: Bilinear

MediaInfo shows “Interlaced” but I suspect the flag is set but the video is not actually interlaced. Idet returns TFF 0 and BFF 0.

With properly interlaced video, idet returns:

Multi frame detection: TFF: 51

I also check the video in VLC with the deinterlacer turned OFF. If the video is interlaced (not just the flags set) then artifacts will stick out like a sore thumb.

I have found that the ffmpeg -vf interlace filter gives properly interlaced video.

Download this video and play in VLC with the deinterlacer turned off to see a properly interlaced video.

www.chrisnology.info/videos/interlaced.mpg

Shotcut does not interlace from progressive. It will let you use interlace encoding and signal as interlace even if progressive, but it does introduce interlace into the imagery as the ffmpeg interlace filter does. The ffmpeg idet filter detects interlace in the imagery outside of the signaling, which is why it is not finding it. I have no plans to add the interlace filter because it affects the frame rate, which is incompatible with our engine.

Thanks for clarifying.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Shotcut does that as well if you turn off Progressive in the Settings menu.

Here is a simple ffmpeg script which adds interlacing and sizes to 1920 x 1080.

I have removed the video low-pass filter which was making the video to blurry.

ffmpeg -y  -i "input.mp4"   -vf scale=out_color_matrix=bt709:width=1920:height=1080:out_range=limited,tinterlace=4  -flags +ilme+ildct  -r 29.97  -color_primaries bt709  -color_trc bt709  -colorspace bt709    -acodec copy  output.mp4

The program virtualdub2 is a video player which will make the retrace lines visible in an interlaced video.

Yes, but the interlacing is impossible to see on such a small image.

This topic was automatically closed after 90 days. New replies are no longer allowed.