Interlace issue on XDCAM conversion

  • Shotcut version 19.12.16
  • Shotcut Settings
    • Video Mode HD 1080i 25fps
  • Operating System OSX 10.10.5 Yosemite
  • Computer Specifications
    • Processor. 2 x 2.66 GHz 6-Corer Intel Xeon
    • Installed Physical Memory (RAM). 12 GB 1333 MHz DDR3 ECC

Hello everybody,
I would like to convert H.264 mp4 files in XDCAM 1080i50 mov files to be used in FCP7 (I know…!!).
I almost got there, but I am still having problems with the interlaced settings. I am using the XDCAM 422 HD preset and then I change the field order to interlaced, Top Field First.
Despite all my effort the clips, actually any clip I import, regardless of their original field order, are converted in progressive.

Does anybody have any suggestions?

Many thanks,

Interlacing is a funny topic. Are you using MediaInfo to check your videos?

It is possible for a program to set a video’s interlace flags without actually interlacing the image. Does that make sense? MediaInfo will then report interlaced. Whether this will pass a facility’s QC has to be determined on a case-by-case basis.

If you need to interlace the actual image, you need to use ffmpeg and the filter tinterlace=4. Virtualdub2 can play back your video with a large image and you can see the interlacing lines in the image if you look closely. Just be sure any deinterlacer is turned off.

Are you familiar with ffmpeg? Have you used it in the past?


Exporting XDCAM in a mov using SC/ffmpeg is “broken”.
I have posted about it on this forum, sorry can’t remember which thread but a search should find it.

Exporting XDCAM in a OP1a mxf container does work, however I’m not sure if FCP7 supports mxf.

Does it have to be XDCAM specifically?
Have you tries ProRes in a mov? This would also fit in nicely with your OS that has generic support for ProRes, you will just have to experiment with the different flavours for ProRes, i.e. Proxy, LT, HQ and so on.

1 Like

How do you know?

I just tested this, and the output I created shows as interlaced in Shotcut Properties and Media Info

Scan type                                : Interlaced
Scan order                               : Top Field First

Shotcut does this too if you turn off Settings > Progressive.

The export preset in Shotcut uses MXF, and while it may not be perfect, it is not broken - even if you change it to mov.

I can tell you that making the container mov, is very much a hit and miss affair.
Don’t know what the cause/s are, but sometimes it will export as progressive, others as TFF and some as BFF, never got to the bottom of it and gave up and only use mxf now.

The mxf export from SC I feed into our Omneon playout servers and are accepted.
Always just export as XDCAMHD 422 (50Mb/s variant not the older 35Mb/s) 1920x1080 TFF.

You need a pretty large image to see the interlace lines, which is why I recommended Virtualdub2. It’s impossible to see the interlace lines in Shotcut’s preview window.

Probably true for most sources, but there’s always the external monitor option for preview that works well.

Just using one monitor and using the controls already existing within Shotcut you don’t need to use to use other software.
Zoom Fit

500% Zoom

1 Like

What is the status of interlace on these exports? Are the flags set? Apparently it’s not an issue that the actual image is not interlaced.

I wonder if the Omneon is taking every other scan line of what is essentially a progressive-scan image and sending them as fields every 1/60 second.

Seems to vary, possibly depending on scan of source.
Either way, the flags are set so it could very well be that the Omneon is sending out fields every 1/50 sec in our case.

Below, a screen grab of some footage I exported from SC.
Interlacing clearly visible:

The screen grab taken from the SC preview window, with “PROGRESSIVE” unchecked and zoom set to 300%.

I’ve tried getting SC to apply interlace to a progressive image with no success. The image, not just the flags. I’ll try it again to make sure. It sets the flags, though.

Are you sure your original footage wasn’t interlaced?

No it does not, but I do not think that is what this thread is about. People should stop replying until the poster responds and clarifies.

Hello everybody and thank you for all the replies. Sorry for the delay, I think we operate on different time zones.

I think some clarifications are needed.
First of all, I work for a broadcasting network, so I do have an external monitor to check the issue of interlaced/progressive fields.
Secondly, our editing stations run FCP7 so everything needs to be converted to .mov files the system can manage. The choice of the XDCAM codec (specifically XDCAM EX 35Mb) was due to the need to balance between quality and file size. All the archive is encoded with this spec so ideally I’d like to keep the continuity.

The files we have to deal with have different specs as they come from different news agencies, I have uploaded three samples in the dropbox folder (link below).
They are progressive, interlaced and most recently some have adopted the MBAFF scan type, which I understand to be an hybrid between progressive and interlaced
( ).
So far we have converted everything via MPEG Streamclip with acceptable results, but the MBAFF scan type is causing Streamclip extremely long time of encoding, which we can’t afford.
So I am looking for other solutions.

Here is a link with three sample files and their respective mediainfo description:

I hope this help clarify a bit my issue.
Thanks everyone for contributing.

I know what a pain it can be.
Our news dept. also has to deal with cellphone footage and a whole lot worse :stuck_out_tongue_winking_eye:

These often need adjustment to levels, colours and so on.
SC works very well for this, but the catch is I have only managed to get acceptable exports
using XDCAMHD (not EX) and in a mxf.

Perhaps others have more ideas or procedures to better suit your needs.

Look at Shotcut’s XDCAM-HD422 preset. Go to Advanced -> Other and change minrate and maxrate to 35M. Also set Format to .mov. Set Shotcut to Interlaced -> Top Field First and see how that works.

Also set Codec->Bitrate to 35M. Don’t know about GOP.

1 Like

GOP = 12 Frames (for HD 50i).
B Frames = 2.

So the GOP should be like such:


1 Like

The 50p video example needs the actual content to be interlaced. But the other two are already interlaced content (and MBAFF can be treated as PAFF here)

In addition to the other suggestions above, you’d also need change the pix_fmt to yuv420p, and the fourcc -vtag to “xdvc” .

Hello everyone,

I would say your solution works, the video is smooth as it is supposed to be, although FCP7 does not understand exactly what the files is (it shows it as progressive although it is clearly interlaced).


I still have a couple of issues but I can work those out.
Thank you all for your support!

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.