Indonesia Coral Reef video - Missing files Tractor?

I’ve just completed a 20 minute video on marine life in a tropical coral reef. When I came to export it as a MP4 file it won’t let me and keeps saying tractor file is missing. My other shorter videos have worked fine. I have the latest version. Reading back in this forum I have see other people have had trouble with this. I have changed the speed the of properties to slow motion in quite a few clips. I have tried restarting it as well as deselecting the hardware encoder… If anyone could help me I would be very grateful - it’s the culmination of weeks of work…
Thanks Neil

Hoia, Neal!

I’ve got a few questions. You’re trying to export a file and it tells you that a file (in this instance a tractor) is missing.

And you write “My other shorter videos have worked fine” though I’m not sure what you mean (beyond the obvious).

Do you mean shorter videos that have no connection to this one beyond the fact that you made them and exported them prior (in other words, you’re addressing the ability to export files in and of itself).

I assume there’s no other connection beyond act of exporting.

That being said, have you tried to tried to close the project – of course saving it prior – then re-open it? I ask because what I want to see is if Shotcut asks you to relocate the file (I expect that it will) upon reopening the project.

And if it does that’s good because all you need to do is just reconnect the file.

If it doesn’t, let us know.

A tractor is a thing that contains a transition. It is called tractor for technical reasons and not normally exposed to the user. Look for an invalid transition and delete (lift) it. It might be difficult to see because it can be as short as one frame making it just a sliver. Also, it might not show during playback because it is on a lower video track with things above it. If you cannot find it upload the project here for someone to repair manually.

Hello Philez,
Yes your assumptions are correct. The other shorter videos were totally different with no play list in common. But this problem is not about trying to find one of the playlist files that I’ve accidentally moved. Missing ‘tractor’ files seem to be about some internal file relating to transitions and timing within Shotgun (from past questions on this topic). I have tried restarting it and I’ve just saved a copy and deleted all the transitions in the video and tried to export again…but the same error comes up.

Ah ok…I’ll go back and see if there are any more transitions hidden. Can they be hidden in audio tracks? and is there any search facility for transitions…?
Thanks Neil

Make a copy of the MLT project file and open up the copy in a text editor (like Notepad++ on Windows), then search for the string “tractor”.

They are not hidden. They are obscured, unexpected, somehow invalid, and/or difficult to see. Yes, they can be on any track. Zoom in the timeline a bit and scroll through the timeline looking for something unexpected. If all looks good, check each transition plays OK. Also, as @Philez suggested, reopen the project, and if you get the missing tractor. Then, use the dialog to replace it with some dummy clip. There is no search unless you want to open the project file in a text editor and look for things and try to understand it.

Ok Thank you both of you. I’ll try this.

And upload a copy if I can’t track the anomaly down…might be tomorrow as it’s getting late here…

Thanks for that. “Tractor” in this instance is a new term for me.

Thanks for that. That’s a new one for me.

Ok I’ve had a look on a text editor and there were a few code lines with tractor in it. I replaced this with word with butterfly but it didn’t make any difference. I’ll upload the file here…
ThanksKUNGKUNGAN2.mlt (849.0 KB)

I fixed your project. The invalid tractor was actually in the playlist, but I do not know exactly what it was attempting to represent originally. <tractor> is also used to represent a nested project (MLT XML as Clip), and it looks related to that but not exactly. You could have found this yourself and removed it if you had been instructed to look there.

KUNGKUNGAN2 - fixed1.mlt (847.6 KB)

Many thanks for this. I would have been absolutely stuck if you hadn’t been able to help me. Thank God for experts! And all the sacrifices you made getting to be one so that you can deal with a niche problem such as this. Thank you.
Just in case it happens again …did you just delete the lines with tractor in it? And when I look at the playlist of the original version (non txt version) I can’t actually see anything untoward in it. Were all the tractor lines in the playlist in the text versions?
Anyway a big thanks once again to your both…

Hi - I just had the same problem and sorted it by removing the item that mysteriously appeared in the playlist. Very helpful thread so thanks all

This topic was automatically closed after 90 days. New replies are no longer allowed.