Imported Videos are stuttering in the Source View

Hi ,
I have a problem imorting videos from my Pixel phone … the Videos are in Full HD. If I import them , Shotcut plays them a bit louder than in VLC and the Sound is stuttering in some cases… The stutter happens allways at exact the same moment. If I export the video I have the stutters in the exported video too…
Any Ideas??
My mashine is a dast Core i7 …

General descriptions will not help much in this forum.

Do you know how many i7’s there?
Look at this list: https://en.wikipedia.org/wiki/List_of_Intel_Core_i7_microprocessors

There are things to look at like video mode, variable frame rate, age of computer, operating system, version number of Shotcut.

When editing video you’re going to get stuttering playback, even on the best of computers. It’s the final product after exporting is.

Back to general terms…
VLC & Shotcut both have volumes you can set for each program.
Once you set it (or mute), it doesn’t change every time you load a new file into either program.
shotcut_2019-12-14_19-14-52 firefox_2019-12-14_19-17-23
shotcut_2019-12-14_19-15-42 vlc_2019-12-14_19-16-44

Hello Hudson, thanks for your answer,
well it doesnt feel like a performance issue because the stutter happens allways at the exact same moment in the video. The overriding sound seems to be a note that something with the audioplayer is not correct… If I turn down the sound the overriding problem consist and of course , the stuttering in the the 3d second , too…And as I wrote , the exported file has exact the problems like the source view verion: The sound is overriding, to loud and sturring ate the same second like the source view video …

I found another thread where the shotcut team provided the solution to convert for editing in the source view


I tried this, but in the result file I have other stutterings which are also exported … so this did not help at all …

maybe something is special with my video? As described the video is from my smartphone Pixel3a…
the framerate is something above 30 fps… is this normal ?

ok I figured out, that all sequences which come from my Smartphone (Google Pixel3a) lead to the described problem. From other smartphone cams there are no problems… I tried to chance the framerate from 30 to 60, I tried to change from 264 to 265 (variable framerate) but no effect… the problem consists … If you developers are interested in my video please provide me with drop zone …

Your frame rate is not true 30fps.
2019-12-16_10-17-34

If you go to Settings, Video Mode it will shows you a bunch of video modes, probably either a 1080p 60fps or a 1080p 30fps selected, unless you created a custom video mode to adapt to your non-true 30fps video source. I’m guessing that it’s set on “Automatic”, thus 1080p 30fps.

You can convert your video file to “Edit Friendly” in Shotcut to attempt to solve the issue.
2019-12-16_10-24-14
shotcut_2019-12-16_10-24-29
shotcut_2019-12-16_10-24-49

It’s common that smartphones record with variable frame rates which this might be the case. Shotcut tries it’s best to warn you to convert when you open the file.

Thanks again for reply… But as I wrote before: Convert to edit Friendly I already tried without success… the converted file is playable in VLC but not in Shotcut…
The other hint was interesting , I created a video mode where i put the exact framerate of 30,061000 … Then I opend a new project using this new video mode… but nothing changed at all… the video is stuttering and overrides exactly like before in the source view… and the exported file takes over these effects…

Hi again… I found a solution which works for me:
On my Pixel3a Phone I installed another CAM app (opencamera)… With this app all the videos imported from this phone work like a charm…
The interessting point is the video format produced by the original Google CAM app … maybe the developers here can play around with some of those videos to optimize the import capabilities of Shotcast…