Importation of Video is permanently damaging clip

I have an MP4 video that Shotcut is unable to import without skipping frames. Changing the settings doesn’t help because by the time the settings can do anything to the file, it’s just polishing the already-damaged clip and retains the skipping.

Shotcut does not write to source/input media files. Maybe the skipping you are seeing is simply in preview. Did you check an export in a media player? As for video mode, its frame rate must be greater than or preferably equal to the source to avoid skipping, of course. If your source is variable frame rate, then that cannot be guaranteed and there will likely be some skipping. If your source frame rate does not match one of our predefined video modes, then it is probably variable frame rate. You can get the closest matching video mode using Automatic.


Now, I see this is a duplicate of your previous thread:

Shotcut is doing the best that it can with the garbage you are giving it.

It is not only happening in preview, and shows up in ever video I’ve exported.

As for variable frame rate, the MP4 is 30 FPS. Shotcut is 30.30, and switching to 30.00 doesn’t fix it.

No need to get snippy. I’ve used other MP4s from the same source, using the same animation, and had zero problems. The fact that it’s occurring only here, in the exact same spot every time, is an oddly specific problem.

No need to make baseless accusations (“permanently damaging”).

1 Like

If you are willing to make your trouble clip available for download (e.g. Google Drive, etc), then I am willing to look at it to see if I can find some ideas to make it work better.

The link is here on Google Drive:

The skipping frames takes place between 8:01:19 and 8:01:20 in Shotcut.

The link is private. You will need to grant me access before I can download the clip. I requested access using my google account.

I changed the privacy so anyone with the link can access it. See if it works now?

I have downloaded the file and am doing some testing.

Here are some observations:

  • Using the “More Information…” tool, it reports:
    • r_frame_rate=1000/33
    • avg_frame_rate=26992500/890753
  • Shotcut uses the avg_frame_rate. But both numbers are very close to the same.
  • I do not see any indication that the video file is variable frame rate

Here are the steps for my testing:

  1. Open the file in VLC video player and view it (particularly around 8:01:19 and 8:01:20)
  2. Open Shotcut
  3. Set the video mode to “Automatic”
  4. Open the file
  5. Play the file in the Shotcut preview (particularly around 8:01:19 and 8:01:20)
  6. Observe that the Shotcut preview seems the same as the VLC playout
  7. Export the file using default settings
  8. Play the exported file in VLC
  9. Observe that the exported file seems the same as the VLC playout

Personally, I can not find a remarkable difference. But maybe I am missing a subtle nuance since the original source material is not perfectly smooth.

I wonder what version of Shotcut you are using. I am using 23.07.29

My problem appears at step 5. The setting is “automatic,” and it still skips frames like clockwork. Exporting doesn’t fix it.

I checked your video too, and it is a problem in the source that Shotcut did not cause. Whatever made that file caused it.

It was an MP4 made from a powerpoint presentation. When I play it back with Windows Media Player, the animation is smooth.

Do you think the Powerpoint origin of the MP4 is the issue?


I tested this on quite an old HP Laptop (running linux) using SMPlayer and VLC, and I am in the same situation as Brian. The beginning of the animation at the 8min mark when it shoots up heading off screen is rather fast in the original.

Using video mode set to automatic, I get what appears to be the exact same result after exporting from Shotcut and I don’t see any noticeable jerkiness (as if frames are being skipped or the player is struggling to keep up).

Yes, in Windows Media Player, the helicopter does not jump up vertically at that time point. Interesting. But with VLC, Shotcut, mpv, and ffplay (FFmpeg’s media player) - all based on FFmpeg libraries, it does skip. I ran ffplay with -loglevel debug, and it reported some problems around that point like “Frame num gap” and “no picture.” But I do not understand those internal details. Shotcut includes a copy of ffplay.exe in the same install directory as Shotcut if you want to report it at

Otherwise, I found a workaround using GoPro Player, which also does not skip. Maybe it is using Windows media framework for playback. It has a File > Export function. I exported it as a new MP4 that does not skip in Shotcut. A remux with ffmpeg.exe did not work, and neither did a transcode using Handbrake (a very popular video encoding/converter tool). Sometimes, there are little compatibility snags like this that requires a workaround like this.

1 Like

The GoPro Player method worked! Thank you, guys, so much. :smiley:

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.