Image Duration option unavailable

Hi there all,

I couldn’t find an answer elsewhere so I am posting this question. Could somebody tell me why, when I drop a picture onto the timeline from a remote folder, the Duration option in the Properties tab is unavailable?

image

If I want to set its duration to exactly one minutes why is this option not available? The image I drop in can be a JPG, a PNG, a GIF, whatever…

I know I can initially drag it longer and/or shorter on the timeline, but this isn’t my issue (when you have issues with your hands and precisely controlling a mouse then you might understand). But, as a side note, when I do manage to drag its duration on the timeline, the Duration counter increments. So why can I not edit this?

An additional issue I have with the “dragging” method is that initially you can drag on the timeline the start and end times of the image you have dropped in. But then, for no apparent reason, even this facility stops and the image duration appears to be “locked” and the only way to drag it again is to remove the image altogether from the timeline and drop it in again from the folder. Stopping and starting ShotCut has no effect on this. When I restart ShotCut and return to this image, if it was “duration locked” on closing ShotCut, it will be “duration locked” on opening it again as well.

Maybe I’m doing something wrong? Thank you in advance for any guidance you can give as to how I can precisely set the display duration of an image that I drop into the ShotCut timeline.

Hi @BeretGascon

To be able to use this Duration parameter, the image needs to be in the Source tab.

For example:

  • Drag an image in the Source/Preview tab

  • Go to the Properties panel

  • Enter de desired duration.

  • To validate, press Enter on your keyboard, or click somewhere outside the Duration field.
    (Don’t use the Set Default button, unless you want all new imported images to have that same length.)

  • Drag the image in the Timeline.

2 Likes

Many thanks for this. I’m going to have to grapple with this because I’m not used to this Source window, but I’ll get there! :stuck_out_tongue_winking_eye:

Thank you
image

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.