How to Reduce Preview Lag?

I want to crop and transcode the files to use in Hitfilm Express. I’ve already done half of the project in Hitfilm so I think if I had to redo it in DVR I’d just throw my hands in the air and quit (already fighting that urge over something else) :frowning:

Thanks for the tip: I can only see two settings that look like they might make a difference: “optimise for computer performance” (now set to on) and “power management mode” (now set to adaptive).

My computer isn’t great but it’s not totally inadequate either:

Mainboard: ASUS Z170 Pro Gaming, board revision 1.04, BIOS v1904
CPU: Intel i7 6700 (6th gen), Stock HSF, Undervolt Offset -0.15 V, LLC 4
RAM: Corsair LPX Vengeance 2x8GB DDR4-3000 (CMK16GX4M2B3000C15)
Graphics: Gigabyte NVIDIA GeForce GTX 950 w/ 2 GB

i’m on a z170 platform as well…it’s been working out just fine…so how did your tweaks work out?

I didn’t notice a difference. Maybe if I had made multiple measurements of the time taken go render I would find a difference but if there was one it wasn’t major.

this may seem kinda old school, and it is…but it’s been my experience that when you are adjusting video settings, it’s best to do them one at a time…click apply… if things go wrong…which they sometimes do, it’s built into windows, (which i’m sure you’ve seen), to revert to your last settings in 15 seconds…which has saved me in the past more than once…if the revert time is too short, (which sometimes it is),…writing your changes down so you have a reference for changing your settings back to the point before a particular program stopped working right really helps. a lot of it is pure experimentation, unless your are extremely proficient at setting up digital video, (which i’m not). this approach has been serving me for a few years. on a side note, i tried a couple of the same settings that were mentioned. i did notice a little difference, but i’m also still experimenting as i go along…i like to test a new setting out for a day or so before i deem it safe, as it were.

Something that solved it for me was going to settings, then unchecking “realtime (frame dropping)”. Instantly went better for me.

This does two things: stops dropping video frames (not foolproof) and uses more CPU threads for the effects processing (but not all of them to 100%!). Obviously, if frames are being dropped (to try to keep the audio more continuous) then it will seem choppy. On the other hand, if each frame takes a long time to compute it will also seem choppy. Thus, it is like the expression “your mileage may vary” but definitely worth a try if you have at least 4 CPU threads.

Is there a plan to add proxy editing feature to Shotcut?
What I mean is an option to automatically create a proxy for the imported videos so we don’t have to hack the mlt or manually rename files/folders.

1 Like

Most likely i would recommend to render it then preview because that might make it easier i am not a shotcut engineer but still might help.

I will make it easier to preview before you render if you turn it back on the preview the audio it should work i think.