How to Reduce Preview Lag?

You’re going to have to change your workflow to suit your computer’s hardware/performance.
Something to try is to create all of your crossfades, then export the entire video to a lossless format, then import and work on that.

Video editing is not a breeze nor is it as smooth as working on photographs. You’re asking your PC to render effects on 24/30/50/60 stills per second in real time. You can imagine this needs real power, right?

What are your PC or Laptop specs?

It’s a gaming PC, 64 bit system with an overclocked i7 processor, 16GB ram, and an Nvidia/MSi GTX970 2GB graphics card… I feel like the program is not able to fully use the hardware I have, but I guess video codecs are different than graphics in a game…

Also, can I get a link to this ProRes format? Or any suggested transcoding options from .MTS/HD-AVC? Busting the project files into chunks and rendering the clips together and then importing them as a single file seems to help reduce perfomance issues, but I can’t help but feel its a waste of time, and that I am somehow losing a little bit of quality every time I render/import, if there is any truth to that

The ProRes is included as all FFMEG codecs are inside. In Intermediate/ProRes

It’s not a waste of time if it helps you complete your project. Also you can use a lossless/H.264 format [see export list] for each of your edited ‘chunks’…

Maybe that could help to batch the re encoding :

If full HD quality is something you don’t need while you are editing you can try to use the “proxy” edition method:

In Hitfilm there’s an option to reduce the preview window to half or quarter quality and this improves performance. Is there a similar feature in Shotcut? I think that would reduce preview lag.

You can manually resize the preview window, but this isn’t the issue because it’s the same source. You need to play around with some of the ‘proxy file’ work-arounds posted on this forum. But bear in mind, even using these methods you will experience preview lag when there are many filters applied. As mentioned earlier, smooth playback in and editor is still very muchdependent on hardware.

GPU and CPU and graphics memory controller utilisation are all below 25% during playback and the only filter applied is a crop. VLC media player plays back the videos perfectly smoothly so I think there is something suboptimal about Shotcut.

I don’t think the proxy methods apply to what I’m trying to do and would make the process take much longer.

25% of a low end CPU/GPU isn’t the same as 25% of a high end CPU and GPU.
It will depend on what CPU and which GPU you have and to a degree how much RAM.

Shotcut is not playing back exported rendered footage, it’s trying to playback footage AND apply the crop filter to EACH FRAME ‘on the fly’.
You expect too much I think :slight_smile:

What are you trying to do??

I made a new thread since I doubt my situation applies to people who can use proxies.

It can apply.
What he just point, is using “compressed” and lighter versions of your clips to edit and just switch at the moment you want to import.

or that :slight_smile:Proxy files - different approach from my workflow with GoPro footage

But there are about 12 moments I want to export so I’d have to switch them back and forth 24 times. It’s not practical.

i’m running two gtx980ti’s in sli mode…i managed to alleviate some lag, and tearing for that matter in other programs such as mspaint which would tear vertically when scrolling horizontally…which made really no sense as i was only dealing with static images…but that’s another story entirely…
anyway, right click your desktop, (if your are using nvidia cards), and click nvidia control panel…and go to 3d settings…in the upper left of the dialog box there is a space to adjust for how your video handles shotcut. scroll down that list until you find shotcut.exe and, (because i have no idea what you have for a rig), play with the settings until you achieve satisfactory results.
nice thing about the nvidia control panel is that if you went and played a little too far on the ragged edge of disaster, you have a button that will restore your programs default settings so you can start over…worked for me.
hope this helps.

1 Like

If you are not happy with Shotcut, try Da Vinci Resolve (DVR) - especially as you say you’re only cropping.
In DVR you can import your media then chose to ‘optimise media’. It does all the work in the background and makes editing even easier.
I find DVR much less laggy than Shotcut for larger projects.

I want to crop and transcode the files to use in Hitfilm Express. I’ve already done half of the project in Hitfilm so I think if I had to redo it in DVR I’d just throw my hands in the air and quit (already fighting that urge over something else) :frowning:

Thanks for the tip: I can only see two settings that look like they might make a difference: “optimise for computer performance” (now set to on) and “power management mode” (now set to adaptive).

My computer isn’t great but it’s not totally inadequate either:

Mainboard: ASUS Z170 Pro Gaming, board revision 1.04, BIOS v1904
CPU: Intel i7 6700 (6th gen), Stock HSF, Undervolt Offset -0.15 V, LLC 4
RAM: Corsair LPX Vengeance 2x8GB DDR4-3000 (CMK16GX4M2B3000C15)
Graphics: Gigabyte NVIDIA GeForce GTX 950 w/ 2 GB

i’m on a z170 platform as well…it’s been working out just fine…so how did your tweaks work out?

I didn’t notice a difference. Maybe if I had made multiple measurements of the time taken go render I would find a difference but if there was one it wasn’t major.

this may seem kinda old school, and it is…but it’s been my experience that when you are adjusting video settings, it’s best to do them one at a time…click apply… if things go wrong…which they sometimes do, it’s built into windows, (which i’m sure you’ve seen), to revert to your last settings in 15 seconds…which has saved me in the past more than once…if the revert time is too short, (which sometimes it is),…writing your changes down so you have a reference for changing your settings back to the point before a particular program stopped working right really helps. a lot of it is pure experimentation, unless your are extremely proficient at setting up digital video, (which i’m not). this approach has been serving me for a few years. on a side note, i tried a couple of the same settings that were mentioned. i did notice a little difference, but i’m also still experimenting as i go along…i like to test a new setting out for a day or so before i deem it safe, as it were.