How to load LUT's

I had a look at other similar posts, but the answer is not clear to me. I have a folder called LUT (linux user by the way) and I downloaded the 35 free lut zip file. extracted all the luts into that folder.

Opened shotcut, selected a video and loaded it into the timeline. Selected it, then filters then LUT (3D) I opened the dialogue to load a LUT, and immediately shotcut crashes… every time.

Is this a bug, or am I doing something wrong please. Version is 20:10:31 and OS is Linux Ubuntu 18.04 lts


It appears to be a bug in the Snap build of Shotcut since we upgraded the Qt library. If you run
instead of using the launch icon or running the /snap/bin/shotcut it adds to your $PATH, then it works. I do not know why.

I would love to have understood your answer but I am not very experienced with command line usage. Could you explain in step form what you mean please? Thanks

I did the test in Ubuntu Studio 20.10.
The Snap version of Shotcut crashes when I try to load any LUT file into the corresponding filter (LUT 3D).
I tried Shotcut in Flatpack version and it worked fine.
In the screenshot Shotcut (flatpack) with a LUT filter (Arabica12.CUBE)

On the Shotcut download page (Linux), there is a link to Flatpack.

From there you will get to something like this:

This should open your Linux system’s application that takes care of software updates and installations.
In my case it is Discover

Run the Terminal app and copy and paste the command provided.

I figured out that it is crashing inside an optional Qt plugin (platformthemes/ I removed that plugin in a test snap build, and the file open dialog for LUT is working now. Testing so far does not reveal any problem without it. As far as I can tell, this plugin simply helps an application find alternative icons when using Settings > Theme > System in Shotcut. That would mean a minor cosmetic difference, but fixing a crash is the more important option. So, this is fixed for the next version.

1 Like

I’m glad you found the problem. :grinning:
Thank you very much. :+1:

Great, thanks very much. Should I still run those commands you gave me? Or just wait for the next version?

This topic was automatically closed after 90 days. New replies are no longer allowed.