Help with missing files on export

hey when i was done with my video and tryed to
export the video this came upUdklip

i would make my day if someone can help

After you saved your project, closed it, and reopened it, what did it show?

hey this came up Udklip
but i tryed to fix it bt getting a
repaired file but it still dosent work

That is the screen I was expecting.

…but there is an additional twist here.

Do you have a file in your project called “+INVALID.txt”?

If you don’t. then this looks like a symptom of a filename being corrupted with characters not legal in a filename in your OS.

This could happen on a project migrated between Mac OS, Windows, Linux, as these three have different rules about file names, such as whether “~” is allowed, or “?”.

It you DO have a file named “+INVALID.txt”, when you double-click, you should get an operating system file screen from which you can navigate to the current location of that file and select it, thus informing Shotcut of its new location.

i dont have a project called “+INVALID.txt” so do i need to make the video from bottom agin ?

+INVALID.txt is a substitute for Shotcut to show something on the screen when a file is missing and ignored. Normally, it still knows the name of the missing file and is able to show you that in the Missing Files dialog. However, something happened, some unknown sequence of steps, that made it lose that information. You could try to click OK and find it and remove it from the project, but you might have to start over.


FWIW we had an almost identical situation, Export failing due to an allegedly missing file, which we managed to cure by editing the confused item out of the Project file.

The only difference in our situation was that when we re-opened our Project file, our missing filename ended with the word “blank” rather than some version of “INVALID” - so:

– Searching the project file for the word “blank”, we found it in one “<producer>” section (in our case with id=“producer72”), and since this seemed like the corrupted item – because as well as
<property name=“resource”>blank</property>
it also had
<property name=“text”>INVALID</property>
…we deleted this whole “<producer>” section.

– We also searched for “producer72” and found it, immediately below, in a “<tractor>” section, which appeared to be just a couple of transitions involving this iffy item - so we deleted this “<tractor>” section also.

– our new Project file, opened and examined in Shotcut, did not appear to have anything missing from the Timeline;
– there had been an app crash a little earlier, before all this happened.
So, conceivably we were adding or changing an item in some strange way that caused an app crash, and left the project with some half-setup item hanging around in there? (I really wouldn’t know, obviously.)
We’re v21.01.29, BTW.

See Dan’s response to a similar post here:

1 Like

Ah, Thankyou very much!

My guy, you saved my life. I have been working on a project for weeks and when I finally finished, it wouldn’t let me export it. I have been up late for like 2 nights just trying and trying to fix it, but I couldn’t. I saw your comment and said “hell, i have nothing to lose” so i tried to do what you said, and it just worked, you have no idea how happy i am right now.

If you still have a copy of the “bad” project file (.mlt) try inputting it to my MLT Analyzer. It should flag the “blank” producer and you can then see the transition which caused it. The analyzer can be found here:

The latest version 21.03 ignores blank and tractor as missing files. Also, it adds an ignore button on this export error dialog. However, you may see INVALID at some points in the video. At least you then get the exact time you see it and go to that place in the timeline to fix it.

1 Like

So this happened to me too and I found a way to replace the “blank” or the “INVALID” thingy.
So first you have to go to the folder where the project is in. Then when you see the mlt file you add a folder with nothing in it next to the mlt file. Then you rename it to the name that shows up in the error and then you can upload it with no problems


This topic was automatically closed after 90 days. New replies are no longer allowed.