GPU processing option dissapeared


I have by default been using the GPU processing option in Shotcut, I think it asked me once when first starting the program and I have been using it since.

On my last project however, I turned it off, mainly to be able to use the Text filter which is unusable with the GPU processing turned on.

That went okay, but now the GPU processing option has completely disappeared from the “Settings” menu. This is a problem because all of my previous projects which were made with GPU processing enabled are now unusable - Shotcut usually crashes when it tries to open them, or they are unusable (I get no video, just static).

I tried turning on OpenGL, but the GPU processing option is still gone. I tried re-installing the whole program, but this doesn’t work either - even after uninstalling the program and then installing it again, the GPU processing option is missing by default, even though it was there the first time I installed Shotcut (I am referring here to identical versions of the software, the latest one).

Is there a solution to this problem? And if re-installation doesn’t work are my old projects unusable forever? Thanks in advance.

The setting was removed since it was error prone and to prevent people to enable it, because they thought this meant GPU acceleration, it is only accessible by command line (Shotcut - Command Line Options). But it is weird that there was a setting within a new version.
As far as I know, the following still holds true:

How do I access the command line?

shotcut.exe --gpu will enable gpu effects.

Could you give me more details? What exactly do I need to open?

If you’re using windows right click the Shotcut shortcut, select properties, add --gpu to the command line.


If I do that to the shortcut, it says the target name is invalid.

Another way to enable gpu is to use regedit.
Goto Computer\HKEY_CURRENT_USER\Software\Meltytech\Shotcut\player

Modify the gpu key to true.


Nevermind, I just used run.exe and it worked. Thanks for the help sauron and samth, the GPU processing setting is turned on now, and I was able to open one of my old files. I think all is good now. :slight_smile:

I don’t understand how to do this can you show me how to use the Run…X in shotcut free video editor so I can so turn usen myself and use it I don’t know where the setting is located
thanks any feedback would be appreciated

Is there a reason why you want to enable it? As I mentioned above, it is an experimental feature and if you encounter problems, you will have to turn it off. Depending on your filters, that might lead to an unusable file so similar to Hurlock’s case.

I wanted to enable it to try to get better preview window playback my preview window playback currently is very stuttering and jerky and unjust unusable I’m hoping that I can just offload the preview window playback on to the GPU my CPU is getting hit very hard just to let you know this is Windows 10 64-bit thanks for the Fast Response any feedback on the question would be most appreciated

Check out this post before attempting to switch GPU processing on:

And as I know so far the text-filter wouldn’t work!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.