Flatpak crash after system update


#1

[I know the topic and the classification seem misaligned, but read on]

Firstly, thank you sooo much for all the work you put into Shotcut.

Secondly, the reason for this post: I wish to understand your approach to using Flatpak, as after a system library update Shotcut is completely unusable for me: it crashes on every file dialogue box access. I am using the latest Shotcut and the log file has no entries close to the time of the crash.

EDIT: Going through my installation notes this problem is with the portable tar installation. I ditched the Flatpak version when it died after it suddenly stopped working and only after running from the command line did I see the reason: the bundled KDE was out of date. Thus the core question remains. Might it be solved with something like “If you’re running the Flatpak, then run this on the command line to update Shotcut…”?

The reason I chose Shotcut is that once I have defined and documented the workflow I will hand over our church’s weekly video edits to an intern on a Mac. She will leave within the year and her replacement might use Windows (and I will still use Linux). Thus, Shotcut.

I’m totally stuck: I have to update system libraries (security and all that), but now I can’t use Shotcut.

Yes, bundling everything in a Flatpack (“Click here to download the version with ALL the libraries”) will be huge, but it won’t fall over. Also, hardly anyone doing serious video editing work is going to use their computer for other things while rendering, so it should be fine to bundle those libraries.

It seems that if another application used said dialogue box recently then Shotcut won’t crash, but I don’t know how to force that (which exact one?) and since my renders take an hour or more I simply don’t have the time to try over and over.

I can’t create a project file, I can’t save my edits, I can’t export to a file — all of which worked until the update.

Is there a reason there is not an everything plus the kitchen sink Flatpak? I can’t use Shotcut … but I really want to!

:sunglasses:
John