Filters after clip conversion don't work

Hi guys,
I’m a newbie in video editing, I started a new project with many clips and tracks two weeks ago.
Now, I’m trying to export a portion of timeline but the memory become full and the export cannot be done. I read that a conversion of source files to friendly-to-edit format will be able to export easier.
I converted a clip in source playlist and the software replaced automatically (wow🤩) the entire edited (with trims and filters) track, but now the filters that I applied to this track seems not to work (if I watch the preview).

Not usually and will not help with memory. There are other better ways to deal with low memory such as using 64-bit, closing others apps, and restarting Shotcut.

I tried to reproduce this but I was unable. I

  1. open existing timeline project
  2. add a Text: Simple filter to track V1
  3. add a Sepia filter to the fourth clip in track V1
  4. double-clicked the file in playlist corresponding to the above clip
  5. clicked Convert in Properties
  6. wait for convert job to finish
  7. review the timeline, checking Properties and preview
  8. see all the filters as before
  9. Save As new project
  10. restart Shotcut
  11. open the newly saved project
  12. still looks fine

Did you try saving as a different project so as to not lose your previous work? Did you try restarting Shotcut and reopen?

Thanks for your reply!

I did everything I could but still doesn’t export, so I tried to convert the source clips.

Unfortunately I overwrite the project but it’s not a big deal becayse I converted only one track.
I tried to restart and reopen shotcut but nothing…
If you want to try to have my issue and fix it, I used video filters like size and position and mask simple shape

Hi Shotcut (is this your nick or I’m really talking with the software? :smile:)
I read the .mlt extension of the project file and, in all sections where the render of filters is wrong, the property “in” of filter is totally a mess!
Luckily, at the end of the section of track there are all the informations about in&out of clips and filters, that made me able to fix the problem, I hope…
So, if you want, and it could help someone, I can post a screenshot of .mlt
Could we call it bug?

The fact is that time of the “in” parameter is doubleed (so there is something wrong) and the “out” stills the same as the original.

I apologize about this, I misunderstood the profile’s graphic :pray:thank’s for your great job! @shotcut

Attach the .mlt file to a reply here.

Do you mean the wrong one or the right one?
Wrong? Cause I’ve already corrected it

I was hoping to get the wrong one, but it sounds like it is not available. It would be ideal if you are able to recreate the problem. Then, you can note your steps and upload the bad project file!

Dimensione Musica - Volare.mlt (551.4 KB)
I did the steps on a copy of project:

  • I splitted a track with filters into many clips (maybe 17/18), the track id is playlist3
  • I converted the video source of track into friendly-to-edit
  • now the track has the same issues of the post’s title
  • you can see that many of “filter in” are doubled

Thank you. I see the problem and reproduced it. This is fixed for the next version 20.06!
A workaround until then is to first select every instance of a timeline clip based on the source media to be converted.