Filters added to the output stop working after 29:43.333 minutes when applied to all clips

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.12.24, 64 bits

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I can in my current project. I noticed that just by opening the .mlt and modifying the file the filter can work for longer:

<filter id="filter1" out="00:29:43.333">
  <property name="version">0.2</property>
  <property name="mlt_service">frei0r.lenscorrection</property>
  <property name="0">0.5</property>
  <property name="1">0.5</property>
  <property name="2">0.26</property>
  <property name="3">0.5</property>
  <property name="shotcut:animIn">00:00:00.000</property>
  <property name="shotcut:animOut">00:00:00.000</property>
  <property name="disable">0</property>
</filter>
<filter id="filter2" out="00:29:43.333">
  <property name="target_loudness">-15</property>
  <property name="window">2</property>
  <property name="max_gain">15.0</property>
  <property name="min_gain">-15.0</property>
  <property name="max_rate">5</property>
  <property name="in_loudness">-16.8732</property>
  <property name="out_gain">1.87323</property>
  <property name="reset_count">281</property>
  <property name="mlt_service">dynamic_loudness</property>
  <property name="shotcut:animIn">00:00:00.000</property>
  <property name="shotcut:animOut">00:00:00.000</property>
  <property name="disable">0</property>
</filter>

My project is definitely longer than 00:29:43.333 minutes.

If you want the same filter to work on all clips in a track then add the filter to the track, not to the clips in the track.
If you add a filter to a clip, it will only work for the duration of the clip on the timeline. even if your project is 2 hours, if a single clip is 29:43, the filter will show out=00:29:00:00 in the .mlt file and you will see one <filter></filter> block, for each clip you have applied the filter to

It is quite possible there is a bug here because whenever the project duration changes the track and output filters must be updated. However, I did not reproduce it, and I need the steps if you can. Uploading an existing project with the problem does not help; how did we get here? For my test, I opened an existing project, added an Output filter, moved the last clip in the timeline further to the right, noted the new duration reported under the player, and inspected the XML only to find its output filter’s out point has the updated duration.

I think it is a bug related to the “Ripple” function, since my filters are in the track and stopped getting updated after I used the “Ripple” function for the first time.

I think I did something like:

  1. Add the filters to the track
  2. Move some filters with “Ripple” enabled
  3. Undo
  4. Save

I will try to reproduce the issue, thank you very much for your interest!