File dialog does not open in Linux

Hello, I have encountered an issue with Shotcut on Flatpak in Linux Mint 20.3 Cinnamon.

So for the past few days, I’ve been trying to find out why nothing shows up when I click on “open file” or “export file”. Usually a file dialog would let me pick which files to open and where I should export to. I’ve also tried to install different versions of Shotcut from APT and the AppImage but I’ve encountered a different issue there (VAAPI not working).

It’s really frustrating since I’d either have to sacrifice hardware acceleration for any ability to export or the other way around where I get hardware acceleration but I can’t export at all.

I don’t know; it is working for me on Ubuntu 20.04

as well as VAAPI in the AppImage. I just tested the flatpak on Mint 20.2 in a virtual machine, and it works there too:

20.2 was already setup unlike 20.3, and I am not bothering to install it because I bet it will work, and I wouldn’t be able to fix it anyways. It is not such a big deal to lose VAAPI because the only good hardware encoder is late model NVIDIA, which uses NVENC not VAAPI.

1 Like

Well, the problem is that I need VAAPI because I don’t have an nvidia GPU. I wonder, is it possible that switching desktop environments can break shotcut? The other day I tried gnome on my Mint install then removed it

Flatpaks use portals to open dialogs in the native look of the desktop, so you get a gnome dialog, when running gnome and a KDE one if running KDE.
It works fine in Fedora 36 (Gnome), but it looks like it don’t work right in your distro or DE.
It is not related to shortcut and can’t be fixed by shotcut.

You can try making a bug report to the Mint team, they might be able to fix it.

1 Like

Just switched to Manjaro a while ago and the problem is no longer present. Seems like I’ve messed up my Mint installation so it’s not really Shotcut’s issue (Don’t add other desktop environments to your Linux install if you don’t know what you’re doing), my VAAPI still aren’t working though but that’s a separate issue. Thanks for the answers

1 Like