Failed to open issue

All of my video files.
I tried mp4, mkv, mpeg, avi … Same result.

Does the folder containing your video files, or the files themselves, have a special character in their names?

In this discussion, Shotcut was not able to open a project with a % character in it’s name.


There is no special character in the names of the files or folders.

I tried to open the same files with Shotcut on the computer of a friend and there was no problem …

The folder containing your videos, is it a sub folder of one or more parent folders?

If so, does any of those parent folders names have special characters?

Sounds like anti-virus getting in the way or you’re trying to access an area of the computer you don’t have granted permission to access.

Try adding an exclusion to Windows Defender to ensure Shotcut is not blocked.

I tried to put my files on Desktop, the complete path is C:\Users\XXXX\Desktop\test, no special characters here.

I tried to add an exclusion on process and files and the problem is still here.
I tried to disable Windows Defender antivirus, same problem.

When I install Shotcut 20-11-28, everything is working perfectly.
Back to the 22.04.25 version, still have the failed to open issue …

What does your Shotcut Log show?
Here is what mine shows.

To get to your shotcut-log.txt file, click on Settings, then
Have this folder open before you exit. Restarting Shotcut resets the log file.

It might be due to Windows Controlled Folder Access

When I disable it or if I add an authorized application I have the same result.

I have 2 warning in the first part of the logs :

And here is the last part where I try to open a mkv file :

The first warning shows that you do not have access to this file.

The libmltavformat.dll is critical. Something in your Windows installation is causing this to fail to load, but I do not know what. What CPU chip is in your system?

I have an Intel Core I5-4670K

Have you tried uninstalling this version of Shotcut, then re-installing it?

Yes, it doesn’t work.
Older version like 20.11.28 works.

Another user reported the same thing in 2020. I suspected an incompatible CPU instruction in the binary is the problem. I asked for his CPU and bought a computer on eBay with same one: Intel Core i5-3470 CPU 3.2GHZ (one generation older than yours). It worked for me. So, we do not know. Maybe you can log in as guest or new user to see if it works, reinstall Windows (yeah right), just use the older version, or use something else. It works for me on 5 different Windows computers from 10 years old to 1.

Same problem with a guest or new user account.
I don’t want to reinstall Windows now because … I just reinstalled it last week, it is a fresh install :slight_smile:

I’m going to use an older version while waiting to change my PC.

Thanks you for the help

This topic was automatically closed after 90 days. New replies are no longer allowed.