Failed to open ASAP :<

I have a “failed to open issue” :< when I try to open my MLT., after all day of work, please help, I need to render this file ASAP :< :<

here is that MLT. File:

I have tried to find error in application log, but it is not there…

From your MLT file:

Shotcut version 19.01.27

That version is over 2 and half years old. When I run that version and try to open your file I get this:


And these errors in the application log

[Error ] [producer_xml] parse fatal: Premature end of data in tag producer line 1646 row: 1650 col: 38
[Error ] [producer_xml] parse fatal: Premature end of data in tag mlt line 2 row: 1650 col: 38

That means your project file is corrupt; it is truncated (missing a part at the end). There is nothing you can do unless you have a backup.

All I can do is edit the project to give you a playlist of the parts of the project that are available. This contains a bunch of clips some with filters. From there you can reconstruct the timeline.

Seminarium 16 - partial.mlt (91.2 KB)

Thanks a lot for such fast response and that partial MLT - it will help to rebuild the file - I’m getting to work! (I have upgrade my shotcut to avoid that error in future).

Some years ago I had similar problems and changed my way of working to alleviate the effects of these (such as losing several days of work). See here fo my solution:

Since this version (but still many versions ago), Shotcut now first saves a new project file to a temporary file, validates its XML, and then only if successful (over)writes the target file.

1 Like

I still remember in 2019 having problems of project files containing nothing but NULLs. This was quite possibly not a fault with Shotcut but with the operating system itself. This was my main reason for changing the way I worked.