Fade-Out works in preview but not after export?

I am new to using Shotcut, and found it quicker to get the job done than OpenShot. I have about 3 clips in a single track, with a Fade-In and Fade-Out filter on each clip. Everything plays great in the preview window. Unfortunately, when I export the video (default 264 profile), the fade-in form black is not working correctly. I get a basically frames (a bit translucent) and then suddenly the video is visible. No nice even fade-in :frowning:. Fade-Out works perfectly.

System: Win10 / Shotcut version 20.02.17

I tried many things to correct including:

  1. delete and then re-add the filter clip
  2. manually create the fade-in (left click throbber?)
  3. Added filter at “Master” level"
  4. start a new project
  5. export to other formats
  6. Hardware encode on as well as off

In all cases, the resulting video file has the same issue. Basically black until past the 1sec filter. no fade-in. Very discouraging.

Can any one help me figure out how to get a simple Fade-In to work? Seems so basic but I am failing.
Insights appreciated!!

I do not reproduce a problem here, and you have not really provided any steps.

How can you see “translucent?”

Show a screenshot of a clip having the problem selected and the filters and keyframes panel.
Or attach your project file.

Kind of hard to to show as in the software it plays fine. After encoding is the problem.
Here is the encoding selections.

encoded file is available here

What I have now found is the “default” export from Shotcut does not play correctly in Win10 Media Player (on my laptop), but plays correctly using VLC.

Any hints how to troubleshoot encoding settings from shotcut would be appreciated.

encoded file is available here

I uploaded here, where it will play in your browser.

I do not see a problem with it. Either you are having a problem with your players, or you are confused about something.
Open that file in Shotcut, turn on View > Scopes > Video Waveform. Next, while paused, return to the beginning and step frame-by-frame and you will see the video level raise for each frame during the first second.

What I have now found is the “default” export from Shotcut does not play correctly in Win10 Media Player

If you changed Export > Advanced > Codec > Quality to 100% then this is a known limitation of Windows media player as it does not support the lossless H.264 profile. Otherwise, I do not reproduce this either.

Thanks @shotcut! Very odd on my side. I will take a look using your hints and see if I can figure out what’s going on. I appreciate the very quick response.

Latest update in case it helps others. If I play the MP4 file on the another Win10 computer, the fade-in works correctly. Seems to be a problem with playback in Win10 Media Player on my laptop. Tired installing K-Lie codec pack on the laptop but that did not help.

Still troubleshooting, but wanted to let the forum know it seems to be laptop related and not Shotcut (but maybe encoding parameters for WMP on my laptop)…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.