Fade filters don't work on .ts


As described in this thread, audio and video fade filters don’t work on at least one example of .ts video file. The bug may also impact other filters, I haven’t checked. Here are the properties of the culprit:
Length: 01:51:09:02
Expected extracted sequence length : about 2 minutes
Codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
25 images / second
Format: yuv420p
Ratio: 16/9
Order: Lower first
Codec: AAC (Advanced Audio Coding)
2 channels
Frequency : 48000
Format: fltp

I found a workaround: export the sequence as mp4 without filters, then reload the extracted sequence and apply the filters to it. The intermediate extracted mp4 sequence has exactly the same video and audion characteristics as the full .ts video, as far as I cal tell.

The bug was reported on v16.09. I just installed v16.11.02 and checked: the bug is still here. This time, the codec I used was libx264.

Currently using Shotcut 17.06.01. This bug is still here. Another user reported the same issue.

I understand this is not a priority issue and may be tricky to solve, but couldn’t Shotcut at least tell users not to try to apply filters when the source video is .ts?

I do not reproduce it. Strange bug seems mainly limited to your system or files.

OK. I’ll try to download a short video from the same source. Then I’ll check if the same problem occurs. If so, I’ll share this video temporarily and I’ll post a lnk to this share so that you can test at least the same video type as me.

If you still can’t reproduce the issue, then it’ll mean your explanation is correct. Does Shotcht rely on the user’s OS to decode videos?

I downloaded a 40MB video from the same place. I added all 4 fade filters (video and audio) and exported. The result had no fade filter applied at all. You can get all THE elements of my test here: https://www.dropbox.com/sh/ins8iwusqalwsky/AABMZNCSS8aE-Jbhpo4wBJHEa?dl=0 . Tell me once you have downloaded the files so that I can clear them from my Dropbox.

Did you try using the throbber instead of manually selecting and applying video and audio fade filters?

I just did so with your La météo du 16 juin 2017 - 20h40_TF1_2017_06_16_20_42.ts file and it works fine. Both video and audio fade just fine.

Here’s my result. I use Windows 10 Pro.

I downloaded the file, and fades are working for me too (v17.06). I even switched my Region to France in case the numeric locale makes a difference. Also, I added the filters from the Filter panel just to change things up from Steve’s test.

Hello Steve,

First of all, I never used the throbber before, nor the timeline, for that matter. First I tried to switch to the English UI to try to find the word “throbber” (not found), then I found another thread where you posted a pdf about fade filters. It took me some time to remember that I had closed a bottom panel in shotcut because I did not believe I needed it. So I found how to reopen that panel (the timeline), then I fumbled around until I found about selecting a section of my source video, then dragging from the video preview to the bottom panel (I really need to read a shotcut manual). I found the throbber (that was not easy, it is well hidden), but when I had done so, I exported… and it worked.

So this does not explain why my way of doing this did not work, but it does make things a lot easier. Thank you.

Hello shotcut,

Sorry, my fault, I thought the bug was in .ts files, but it was in the procedure.

When you wrote that you did not reproduce my bug, I was surprised. Then I thought that maybe you had missed the selection part. So I used the same source, added the fade filters (without changing the default selection), exported and indeed the fades were applied. As a second test, I reloaded Shotcut, selected a subset of the video, added the fade filters, exported, and the fades were not there. Then to be sure, I used another video source, a mp4, and did the same test and got the same bug. So the real procedure to trigger the bug is:
1 - load a video (I always use drag and drop, BTW)
2 - select a part of this video (I always use the “i” and “o” keys for this)
3 - add the fade filters (I tested with only the video in filter and I got still got the bug, so you don’t need to add all 4 filters to see the issue)
4 - export

This means that the title of this bug is entirely misleading, my fault. But there is still a bug :slight_smile:

Well, glad it worked for you but I’m not sure about your unusual workflow.
To try and do everything using only the preview window and not the timeline isn’t how a video editor is generally used.

I understand this, but my needs are very limited. I only need to export selected parts of videos and apply fades to them. Maybe someday I’ll find some reason to try more complex video editing…

OK, I reproduced that bug, and I will try to fix it. It is definitely not supposed to be required to use the Timeline!

Excellent! Thank you. In the meanwhile, I’ll use the Timeline.