Extreme lag (in Preview) to the point of unusability in Shotcut

Using Windows 10 Home and Shotcut v20.06.28

I have used Shotcut since 2018 and there are always issues with complicated effects on videos (only 1080p) making my program lag a lot, to the point where tasks like alinging video with music is an absolute chore to do. Bear in mind I do not edit 4k video, just 1080p 30fps and 60fps for YouTube.
Sometimes it is impossible to use, and today its ok (see video) compared to how it was sometimes.

The project shown in the recording only has effects such as colour grading, mask (from file) and size and position across 3 or 4 tracks.

Ryzen 5 1600 @ 3.6Ghz
GTX 1060 6GB
16GB DDR4 2133mhz RAM (yes I know this is slow but its all I had the money for at the time)
7200RPM 1TB HDD (where the video is pulled from) Seagate ST1000DM003-1ER162 (SATA)
128GB M.2 SATA SSD (boot drive) ADATA SU800NS38 (SATA (SSD))

I have tried to turn off multiple settings such as Real Time and Scrub Audio and used preview scaling at 360p, both with minimal increaes in performance. The OBS footage I input into Shotcut is just an MP4

video link:

First, download the latest version of Shotcut which is 20.11.28 that was released last month.
Second, have you used Proxy along with Preview Scaling?

I didn’t use them at the same time so i’m gonna try, i’ll let you know if its successful

In addition to Proxy and Preview Scaling, changing Settings > Display Method from Automatic to Open GL made a noticeable difference for me.

Why does this influence? Is there any additional information about the different display modes and their impact on performance?

Someone mentioned it in a thread a few weeks ago @ejmillan, I tried and I noticed a difference.

1 Like

I will search with some keywords to see what information I find. Thank you.

1 Like

I found the documentation and I know why I didn’t notice the difference. :robot:

In my case, the automatic mode is set to OpenGL (as I could check reading the Shotcut log), so there is no difference if I set automatic or directly OpenGL as a display method.

1 Like

Hi @ejmillan. Reading this makes me think that maybe the only reason I noticed a performance improvement was because changing the display method requires to restart Shotcut.

Simply set the display method to automatic mode and view the log to see which display mode Shotcut chooses for you. This way you can know if in your case there is a change of visualization method.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.