Exporting D10 results in empty files

I’m trying to export a timeline with a single clip as D10 (SD PAL) using the standard preset. The export job starts as expected and CPU usage in task manager increases. After the job has finished the target file is quite small (60 KB) and does not seem to contain any encoded video or audio information. Nevertheless, the MXF header seems to be written correctly, according to MedieInfo report:

Format                    : MXF
Format version            : Version 1.3
Format profile            : OP-1a
Format settings           : Closed / Complete
File size                 : 67.5 KiB
Encoded date              : 0-00-00 00:00:00.000
Writing application       : FFmpeg OP1a Muxer
IsTruncated               : Yes

ID                        : 2
Format                    : MPEG Video
Format version            : Version 2
Format settings, wrapping : Frame (D-10)
Codec ID                  : 0D01030102010101-0401020201020101
Width                     : 720 pixels
Height                    : 576 pixels
Display aspect ratio      : 4:3
Frame rate                : 25.000 FPS
Standard                  : PAL
Color space               : YUV
Chroma subsampling        : 4:2:2
Bit depth                 : 8 bits
Scan type                 : Progressive
Compression mode          : Lossy
Transfer characteristics  : BT.709

ID                        : 3
Format                    : PCM
Format settings           : Little
Format settings, wrapping : Frame (D-10)
Codec ID                  : 0D01030102010101
Bit rate mode             : Constant
Bit rate                  : 4 608 kb/s
Channel(s)                : 6 channels
Sampling rate             : 48.0 kHz
Frame rate                : 25.000 FPS (1920 SPF)
Bit depth                 : 16 bits
Locked                    : Yes

Other #1
ID                        : 1-Material
Type                      : Time code
Format                    : MXF TC
Frame rate                : 25.000 FPS
Time code of first frame  : 00:00:00:00
Time code settings        : Material Package
Time code, striped        : Yes

Other #2
ID                        : 1-Source
Type                      : Time code
Format                    : MXF TC
Frame rate                : 25.000 FPS
Time code of first frame  : 00:00:00:00
Time code settings        : Source Package
Time code, striped        : Yes

I also tried the different D10 presets, played around with the advanced settings and disabled parallel processing, with the same results. There is propably an issue regarding the mxf_d10 format.

As source files I want to use ffv1 files (yeah, I know, not the typical input format) and already tried other formats, resulting in the same issues.

Any help on this topic would be appreciated.

Additional informations:
Shotcut version 20.04.12
Video Mode: SD PAL
Display Method: Automatic

Windows 10 x64
i5-4670k, 3.40 GHz, 4 Cores, 4 Logical
16GB RAM (7.8GB available)

Thank you and best regards

I made a quick test, reproduced problem, looked in the export log:
[mpeg2video @ 0x7f8048001dc0] VBV buffer too small for bitrate

Go to Export > Codec > Buffer size and increase it, but I still could not get it to succeed. Now it always fails with
[mxf_d10 @ 0x7f30e4000f40] track 0: frame size does not match index unit size, 86990 != 250000

Something may have changed in a FFmpeg upgrade that breaks this preset. If you figure it out, please let us know!

Thank you for the advice, I will keep you posted.

OK, I have found a solution that works for my case: I replaced all ffmpeg dlls with version 4.2.3 and edited some of the advanced settings (for D10 PAL):

Video Resolution: 720 x 608
Codec Buffer size: 244,00 (no change)
Audio Channels: 6
Codec: pcm_s16le


I don’t know if replacing all ffmpeg dlls causes any issues but for me everthing is fine now!

You should try not doing that as current Shotcut version already includes that.

Video Resolution: 720 x 608

Why? That is a bad resolution for SD PAL, and Shotcut will see that your interlaced inputs with 576 height have a different vertical resolution and deinterlace it.

I see you removed:


That probably helped create an expected frame size, but D10 is supposed to be all intra frames.


That does nothing. 608 - 32 does equal 32, but it is neither a MLT or FFmpeg option that appears in the output of ffmpeg-h full.

Weird. Unfortunately, I will not be able to include these.

This topic was automatically closed after 90 days. New replies are no longer allowed.