Exporting > 1-5K videos

When I export a video I succeed in getting a file larger than 1-5K one of about 15x. The few times I get something I can play I don’t understand what I did differently…

After accepting the default and then following a number of tutorials and not getting anywhere, I finally decided, that I would follow, to the letter, the
How To Export a Video in Shotcut Video Editor Tutorial (2020!) For YouTube
[(99) How To Export a Video in Shotcut Video Editor Tutorial (2020!) For YouTube [How To Export a Video in Shotcut Video Editor Tutorial (2020!) For YouTube - YouTube]

I’m now consistently able to get a mp4 Video file 1-5K in length that does nothing every time.

  1. I have been unable to save the settings as a Custom Preset so I have to replay the video every time I retry an export.
  2. Task editor seems to chug along showing cpu and memory usage.
  3. Nothing in the Application Log speaks of running out of memory, but I’m not sure what the Log is referring to because there is no obvious way of clearing the log, even by quitting and restarting the program.
  4. I see multiple timelines in How To Export a Video in Shotcut Video Editor Tutorial (2020!) For YouTube - YouTube but only have one up in Shotcut - a video timeline which also seems to have audio since I can play it and hear perfectly synced audio.

There’s something very basic I’m missing…

Any help would be appreciated.

1-5K ? Do you literally mean 1.5 kilobytes ?
Can’t be…

Or do you mean 1.5 G (gigabytes) ?

Also, please tell us what version of Shotcut you use and your operating system (Windows, Mac, Linux)

Are you using hardware encoding?

Please excuse me for not replying sooner. (I never noticed a notification.)

I use Shotcut 22.04.25; Win10 Pro

I’m serious, what I end up with, as often as not, is a file 0K to 5K large.
The videos I start out with are (15 minute to 45 minute) presentations I’m just trying to save to review later.

I record using OBS Studio in .mkv format, and redux it to .mp4.
I’m not trying any of the special features of Shotcut (overlapping scenes, transitions, etc.) just:
a) placing the mp4 in the Playlist
b) double clicking on it
c) sliding it onto the Timeline
d) running through the sound part of the Timeline and executing a ‘Split at Playhead’
e) deleting what comes after the split

f) activating [Advanced] and using a Custom Preset I constructed that should correspond to what YouTube requires. To wit:
f=mp4
acodec=aac
channels=2
ar=48000
ab=384k
vcodec=libx264
crf=23
g=300
bf=3
width=1920
height=1080
aspect=1.77778
progressive=1
top_field_first=2
deinterlace_method=yadif
rescale=bilinear
frame_rate_num=60000025
frame_rate_den=1000000
threads=0

Gee…This video seems to actually be working…
45:13:23 257 MB It took about an hour to Export.

Next to figure out:

  • why the image is so small
  • how to compress the file size

I don’t know:
In the export pane it says “Use hardware encoder” and next to that [Configure…]
Clicking on ‘Use hardware encoder’ brings up a checkmark
Clicking on the button [Configure…] shows a 6-item list with
h264_nvenc and h264_qsv checked

I have no idea what I’m doing here.
Without Use hardware encoder checked, it took about an hour to make the 45 minute video.
I’ll see how long it takes with hardware encoder checked…

NVENC = Nvidia Encoder → use the video card to encode (recommended if you have a good video card)
QSV = intel quick sync video → use the CPU’s integrated video card to encode

After you enable the checkmarks you can use the hardware encoding by choosing a codec that has NVENC or QSV in name (ie: h264_nvenc or h264_qsv).

1h export time for a 45 min video is quite expected for standard encoding. You can get faster speeds only by sacrificing quality or filesize (or getting a very powerful CPU).

This is actually a very good file size, only 250MB for 45 mins of footage. You can technically get any filesize you want, but how low do you want to go?

What do you mean by image so small? Can you show a screenshot of the project?
There are 2 ways to lower the file size:

  1. lower the quality (this is the crf/quality number in the export page)
  2. use a more advanced codec (like x265/HEVC) or lower the preset speed → but this will increase your encode time by 2-3x with only <50% file size reduction, not sure you want this

Note that if you use a hardware encoder you’ll get even bigger file sizes, but faster. Sadly there’s no way to get good filesize, good quality AND good speed.